I've been trying to install the packages needed to upgrade my glib to 2.2.0. However, after I've installed atk 1.2.0 and run configure and I try to make, it keeps giving this error:

/bin/sh: line 1: /usr/local/atk-1.2.0/atk/..//usr/local/glib-2.2.0/gobject/glib-genmarshal: No such file or directory
make[2]: *** [stamp-atkmarshal.c] Error 127
make[2]: Leaving directory `/usr/local/atk-1.2.0/atk'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/local/atk-1.2.0'
make: *** [all-recursive-am] Error 2

I've run ldconfig in the glib-2.2.0 directory and I've set my PKG_CONFIG_PATH env var to also include the paths to glib-2.2.0 and /usr/local/lib, but I'm still getting the same error. I'm doing this all as root since I'm installing everything in /usr/local.

I'm using Mandrake 9.1

any ideas?
thanks