Help - Search - Members - Calendar
Full Version: Why Won't My Internet Work?
Linuxhelp > Support > Technical Support
TheFastCat
So I've installed the necessary drivers for my nForce2 ethernet and Realtech RT8139 chips (or something) and I still can't connect to the internet! I have dsl and a linux-compatible router which is connected directly to my internet-enabled Mac (so it seems as though the router is working). On my Linux computer I have configured my connection for DSL and enabled DHCP with dynamic IP addressing and stuff, and when my system starts up and I view the "verbose logging" it even assigns my ethernet jack (I have 2 on my motherboard) an IP address -- but only one of them -- I think because only one of them is connected to the router (other one empty). This means it must be communicating with my router, right? And yet when I try to load a web-page via Konquerer it won't work.

ROUTER - D-Link DI 624
Modem - Westell
ISP - Verizon

any Ideas on where to look next?

edit: Router model typo
hughesjr
If you are plugging in your Linux machine to your router and your router is plugged in to your DSL modem, then you do not need to setup DSL in SUSE.

Your ethernet card is all that need to be setup...and it needs to be set for DHCP.

After setting up DHCP, type this command in a terminal window:

ifconfig

The results should look like this:

CODE
eth0     Link encap:Ethernet  HWaddr 00:04:5A:40:93:F5
         inet addr:192.168.0.26  Bcast:192.168.0.255  Mask:255.255.255.0
         inet6 addr: fe80::204:5aff:fe40:93f5/64 Scope:Link
         UP BROADCAST NOTRAILERS RUNNING MULTICAST  MTU:1500  Metric:1
         RX packets:188 errors:0 dropped:0 overruns:0 frame:0
         TX packets:188 errors:0 dropped:0 overruns:0 carrier:0
         collisions:0 txqueuelen:100
         RX bytes:137487 (134.2 Kb)  TX bytes:57510 (56.1 Kb)
         Interrupt:5 Base address:0xe000


You should also have a lo section ... but it's not important in this discussion.

If you have an IP address for the linux machine (mine is 192.168.0.26 in the example), try typing the command:

ping www.yahoo.com

and see if it works ... the results should look something like this:

CODE
PING www.yahoo.akadns.net (216.109.118.74) 56(84) bytes of data.
64 bytes from p11.www.dcn.yahoo.com (216.109.118.74): icmp_seq=1 ttl=45 time=53.2 ms
64 bytes from p11.www.dcn.yahoo.com (216.109.118.74): icmp_seq=2 ttl=45 time=65.6 ms
64 bytes from p11.www.dcn.yahoo.com (216.109.118.74): icmp_seq=3 ttl=45 time=321 ms
64 bytes from p11.www.dcn.yahoo.com (216.109.118.74): icmp_seq=4 ttl=45 time=56.6 ms
64 bytes from p11.www.dcn.yahoo.com (216.109.118.74): icmp_seq=5 ttl=45 time=51.8 ms

--- www.yahoo.akadns.net ping statistics ---
5 packets transmitted, 5 received, 0% packet loss, time 4040ms
rtt min/avg/max/mdev = 51.817/109.699/321.073/105.796 ms


If that doesn't work try this:

ping -c 5 216.109.118.74

The results should be like this:

CODE
PING 216.109.118.74 (216.109.118.74) 56(84) bytes of data.
64 bytes from 216.109.118.74: icmp_seq=1 ttl=45 time=55.6 ms
64 bytes from 216.109.118.74: icmp_seq=2 ttl=45 time=56.9 ms
64 bytes from 216.109.118.74: icmp_seq=3 ttl=45 time=50.3 ms
64 bytes from 216.109.118.74: icmp_seq=4 ttl=45 time=64.8 ms
64 bytes from 216.109.118.74: icmp_seq=5 ttl=45 time=50.8 ms

--- 216.109.118.74 ping statistics ---
5 packets transmitted, 5 received, 0% packet loss, time 4035ms
rtt min/avg/max/mdev = 50.394/55.726/64.809/5.216 ms


If the first ping doesn't work but the second one does, the problem is with your DNS server setup ... if neither work, you have a network card problem.

Try pinging the router (usually 192.168.x.1 ... x being whatever it is in your IP address (usually either 0 or 1).
TheFastCat
So when I type in ifconfig on my konsole, it says something like "command not recognized" -- do I have to be in the root to use it?

I couldn't ping yahoo nor that network address you gave ( ping -c 5 216.109.118.74) *but* I could ping my router! (which is good, right?). I disabled my dsl configuration and now everything is DHCP. And that lo thing you mentioned sets itself up just before my eth0 and eth1 during verbose startup.

any ideas on why ifconfig wasn't recognized on the console? (as in -- how did I mess that up). Any ideas on what to do next? Seems like I'm missing a piece of the puzzle...

Also -- I have two seemingly different network adaptors -- 1 for each of my two ethernet jacks, that's kind of weird, isn't it? Why aren't both nforce 2s?

Thanks for the help!
hughesjr
You can run ifconfig as non-root ... but it is in /sbin (not in a normal users path)...

so type /sbin/ifconfig instead...

If you can ping the router but not the rest of the world, then either the router is not setup properly OR the default gateway for the eth0 is set incorrectly...
TheFastCat
so I used ifconfig and got that same stuff you demonstrated exactly. My linux computer can also ping all of the computers on my router as well as browse 192.168.0.1 (my router's address) in the web browser and mess with all of the settings. But I still can't ping yahoo or it's numeric address. So I'm frustrated because I can't think of what's happening that won't let it connect to the web... It's as if It can't look beyond my router at all (or at least that's what it seems like). the only thing that I can think of is that I have my default gateway set as my Router's IP but on my router's set up page it lists the default address as the address for the WAN (DSL modem) port. so am I right to have the default address set to the router??

So frustrated... Any ideas what to change or where else to get help? sad.gif

telephone support etc. even
hughesjr
The default gateway should be 192.168.0.1.

On a machine that works, do a trace route to a known outside address. If you have a windows machine, do the command:

tracert -d www.yahoo.com

The output should look something like this (although your IPs will be different):
CODE
Tracing route to www.yahoo.akadns.net [216.109.118.67]
over a maximum of 30 hops:
                                                                                                           
 1    <1 ms    <1 ms    <1 ms  192.168.0.1
 2    16 ms     9 ms     8 ms  10.98.64.1
 3     5 ms     5 ms     6 ms  24.170.32.37
 4     5 ms     5 ms     6 ms  24.170.32.125
 5    10 ms     9 ms    12 ms  24.93.33.229
 6    11 ms    13 ms    12 ms  24.93.33.161
 7    20 ms    11 ms    11 ms  66.185.133.145
 8    12 ms    11 ms    11 ms  66.185.146.96
 9    16 ms    17 ms    16 ms  66.185.152.132
10    16 ms    18 ms    17 ms  66.185.133.97
11    17 ms    17 ms    15 ms  66.185.133.190
12    18 ms    17 ms    15 ms  209.244.15.165
13    49 ms    49 ms    49 ms  64.159.0.138
14    48 ms    48 ms    47 ms  64.159.18.67
15    50 ms    49 ms    50 ms  63.210.59.254
16    51 ms    50 ms    51 ms  216.109.120.142
17    51 ms    49 ms    50 ms  216.109.118.67
                                                                                                           
Trace complete.


On the linux machine, the command to get the same thing is:

traceroute -n www.yahoo.com (or traceroute -n 216.109.118.78). The results are:

CODE
traceroute: Warning: www.yahoo.com has multiple addresses; using 216.109.118.78
traceroute to www.yahoo.akadns.net (216.109.118.78), 30 hops max, 38 byte packets
1  192.168.0.1  0.301 ms  0.837 ms  0.231 ms
2  10.98.64.1  15.404 ms  8.098 ms  7.955 ms
3  24.170.32.37  8.623 ms  9.519 ms  8.765 ms
4  24.170.32.125  9.556 ms  8.956 ms  9.902 ms
5  24.93.33.229  12.982 ms  14.155 ms  14.078 ms
6  24.93.33.161  14.253 ms  14.601 ms  13.533 ms
7  66.185.133.145  14.216 ms  14.392 ms  15.505 ms
8  66.185.150.148  13.797 ms  16.380 ms  16.512 ms
9  66.185.152.132  23.668 ms  19.763 ms  20.679 ms
10  66.185.133.97  19.819 ms  19.482 ms  20.205 ms
11  66.185.133.190  29.713 ms  20.044 ms  19.842 ms
12  209.244.15.165  20.076 ms  20.099 ms  19.817 ms
13  64.159.0.138  52.115 ms  52.139 ms  52.120 ms
14  64.159.18.3  53.558 ms  52.560 ms  52.222 ms
15  63.210.59.254  53.697 ms  58.521 ms  54.797 ms
16  216.109.120.146  54.610 ms  53.836 ms 54.070 ms
17  216.109.118.78  54.841 ms  55.290 ms  52.755 ms


Now you can see if the problem is at your router or somewhere else ... If the windows machine can go outside, but the Linux machine can't then you need to troubleshoot the router settings...The router might have a place in the setup that restricts clients. You may need to authorize the IP address that the linux machine has to access the internet on your router...

How you can test that is to figure out the IP address of one of your other PCs (in windows use the command ipconfig in a command prompt) ... then turn off that computer and manually assign that same IP address to your Linux machine ... you will need to assign the IP address (same as the other PC you secured), the default gateway (192.168.0.1) and the DNS server (192.168.0.1).

Now test the Linux machine ... if it works the router needs to be adjusted ... if the Linux machine can still do local and not external things then I am at a loss...
TheFastCat
It was my DNS ! It works now! Hugh is a genius! Thank you sir! biggrin.gif !!!!!
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.