Help - Search - Members - Calendar
Full Version: Noob Question -- Nvidia Driver Install (suse 8.2)
Linuxhelp > Support > Technical Support
TheFastCat
I'm attempting to install NVIDIA drivers on my newly-installed SuSE 8.2. The driver README says that in order to install the drivers, I need to boot directly onto my VGA console and not into X from the root. It says that this is normally done by editing my /etc/inittab file.

Can anyone tell me how to do boot directly onto my VGA console while in the root? Otherwise I'm going to have to pay the SuSE tech support people $40 for about 5 minutes of help dry.gif. Thank you!

installation readme here for reference
hughesjr
When booting up, type 3 in the optional kernel parameters box and press enter! (that is the text box at the bottom of the screen when you select the kernel to boot with)


I'll take half of the $40.00 in small unmarked bills smile.gif (just kidding!)
TheFastCat
THanks hugh! That was easier than I thought it would be! Can you help me to figure out how to do the next step (editing my XFREE86 log file)? I can find the file "/var/log/XFree86.0.log" but I don't know what to do once I get there. The driver installation told me to to use "SaX2 now to enable the driver" -- NVIDIA's readme file below seems to be saying something else -- any idea on what I need to do? Thanks.

QUOTE
(sec-03) EDITING YOUR XF86CONFIG FILE
__________________________________________________________________________

When XFree86 4.0 was released, it used a slightly different XF86Config
file syntax than the 3.x series did, and so to allow both 3.x and 4.x
versions of XFree86 to co-exist on the same system, it was decided that
XFree86 4.x was to use the configuration file "/etc/X11/XF86Config-4"
if it existed, and only if that file did not exist would the file
"/etc/X11/XF86Config" be used (actually, that is an over-simplification
of the search criteria; please see the XF86Config man page for a complete
description of the search path).  Please make sure you know what
configuration file XFree86 is using.  If you are in doubt, look for a
line beginning with "(==) Using config file:" in your XFree86 log file
("/var/log/XFree86.0.log").  This README will use "XF86Config" to refer
to your configuration file, whatever it is named.

If you do not have a working XF86Config file, there are several ways
to start: there is a sample config file that comes with XFree86,
and there is a sample config file included with the NVIDIA driver
package (it gets installed in /usr/share/doc/NVIDIA_GLX-1.0/).
You could also use a program like 'xf86config'; some distributions
provide their own tool for generating an XF86Config file.  For more
on XF86Config file syntax, please refer to the man page.

If you already have an XF86Config file working with a different driver
(such as the 'nv' or 'vesa' driver), then all you need to do is find
the relevant Device section and replace the line:

        Driver "nv"
    (or Driver "vesa")

with

        Driver "nvidia" 

In the Module section, make sure you have:

        Load  "glx"

You should also remove the following lines:
     
        Load  "dri"
        Load  "GLcore"

if they exist.  There are also numerous options that can be added to
the XF86Config file to fine-tune the NVIDIA XFree86 driver.  Please see
Appendix D for a complete list of these options.

Once you have configured your XF86Config file, you are ready to restart
X and begin using the accelerated OpenGL libraries.  After you restart X,
you should be able to run any OpenGL application and it will automatically
use the new NVIDIA libraries.  If you encounter any problems, please
see the FREQUENTLY ASKED QUESTIONS section below.
TheFastCat
THanks hugh! That was easier than I thought it would be! Can you help me to figure out how to do the next step (editing my XFREE86 log file)? I can find the file "/var/log/XFree86.0.log" but I don't know what to do once I get there. The driver installation told me to to use "SaX2 now to enable the driver" -- NVIDIA's readme file below seems to be saying something else -- any idea on what I need to do? Thanks.

QUOTE
(sec-03) EDITING YOUR XF86CONFIG FILE
__________________________________________________________________________

When XFree86 4.0 was released, it used a slightly different XF86Config
file syntax than the 3.x series did, and so to allow both 3.x and 4.x
versions of XFree86 to co-exist on the same system, it was decided that
XFree86 4.x was to use the configuration file "/etc/X11/XF86Config-4"
if it existed, and only if that file did not exist would the file
"/etc/X11/XF86Config" be used (actually, that is an over-simplification
of the search criteria; please see the XF86Config man page for a complete
description of the search path).  Please make sure you know what
configuration file XFree86 is using.  If you are in doubt, look for a
line beginning with "(==) Using config file:" in your XFree86 log file
("/var/log/XFree86.0.log").  This README will use "XF86Config" to refer
to your configuration file, whatever it is named.

If you do not have a working XF86Config file, there are several ways
to start: there is a sample config file that comes with XFree86,
and there is a sample config file included with the NVIDIA driver
package (it gets installed in /usr/share/doc/NVIDIA_GLX-1.0/).
You could also use a program like 'xf86config'; some distributions
provide their own tool for generating an XF86Config file.  For more
on XF86Config file syntax, please refer to the man page.

If you already have an XF86Config file working with a different driver
(such as the 'nv' or 'vesa' driver), then all you need to do is find
the relevant Device section and replace the line:

        Driver "nv"
    (or Driver "vesa")

with

        Driver "nvidia" 

In the Module section, make sure you have:

        Load  "glx"

You should also remove the following lines:
     
        Load  "dri"
        Load  "GLcore"

if they exist.  There are also numerous options that can be added to
the XF86Config file to fine-tune the NVIDIA XFree86 driver.  Please see
Appendix D for a complete list of these options.

Once you have configured your XF86Config file, you are ready to restart
X and begin using the accelerated OpenGL libraries.  After you restart X,
you should be able to run any OpenGL application and it will automatically
use the new NVIDIA libraries.  If you encounter any problems, please
see the FREQUENTLY ASKED QUESTIONS section below.
hughesjr
The easiest thing to do is to edit your /etc/X11/XF86Config file...put a # in front of dri and/or GLcore:

#Load "dri"
#Load "GLcore


Go to the driver line and change from nv or vesa to nvidia.

if you run the command sax2 from the command line, it might make the adjustments for you ... if not, you can manually make them.

The program I would recommend for editing in console mode is vim. It is hard to learn, but I use it exclusively on Linux, Solaris and HPUX machines...once you learn vi you can use it anywhere, I hardly ever open a graphical text editor in Linux...

Here are instructions on how to use vi (and emacs) console text editors... Here is vim specific help...even better, Here is basic keys in vi ...

in this case, move to the line in question (the beginning of load dri, for example)... press i for insert mode and a line will appear at the bottom of the sceen that says ---INSERT---. Now type # then use the arrows to move to the l in load GLcore and put a # there too. Now move to the Display line and use the Del to remove the nv or vesa and type nvidia. Your lines should now look like this:

#Load "dri"
#Load "GLcore
Driver "nvidia"


If they do, press esc to exit insert mode, then press : to enter command mode for vi, and type w! to save the XF86config file. If all looks well, press : then q! to exit.
TheFastCat
Thanks again, hugh! This problem is now solved cool.gif
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.