The main thing is how do I get /dev/ttyS4 to show up on the Device dropdown list?

I've been working with this since thursday. Had a Zoom modem, now I have a US Robotics model 5610b that is Linux compatible. still trying to get online with it.
I'm using a Mandrake 9.1 distru. this is what I have done so far with no luck.

Ran "cat /proc/pci" got these results:
bus 1 device 11 function 0:
IRQ 10
I/o at 0xxf8 [0xxccff]

ran "wvdialconf /etc/wvdial.conf" got a lot of tests on speed and got this: found modem on /dev/ttys4

tried this next "setserial /dev/ttys4 irq 10 port 0xccf8 uart 16550a" and then I got no error or anything just went to the next line on :root.

Tried a qwery on the modem and when it showed all the ati boxes they were all blank. It says that the modem is ready but it just never connects. In devices I dont' see a /dev/ttys4 setting either. these are just things I've tried from other fourm threads that I've found today. I know this modem works with linux I just don't know the command lines past what I've tried so far.

Thanks MP