Help - Search - Members - Calendar
Full Version: Networking Trouble
Linuxhelp > Support > Technical Support
Roint
I'd like to ask someone about a problem I'm having with my home network, with two computers, one running Win98 and another (mine) running Slackware Linux. For some reason, I cannot ping the other computer's hostname, but i can ping it's ip address. This goes for both computers. When I try to mount a windows shared directory with:

mount -t smbfs -o username=**,password=** //win98hostname/hd/ /mnt/win98

in Linux, it gives me this error:

Tree connect failed: ERRSRV - ERRinvnetname (Invalid network name in tree connect)

I have Samba installed and configured, and I can ping the computer with it's ip address.

This never happened before i reinstalled Slackware.

Roint
Joey
Do you have the hostnames listed in /etc/hosts ?
hughesjr
if the windows name is not the same as the domain name, you can add entries in the /etc/samba/lmhosts file in the same way as the /etc/hosts file...
Roint
Thanks to both of your advice, I can now ping both computers, from both computers with their hostnames, but I still get the error message when I try to mount the shared directory from Linux.
hughesjr
I just booted up my Slackware 9.1 drive ... and setup samba. It worked OK with my RedHat smb.conf file...

Type the following command in a terminal window (on the linux machine):

ps -ef | grep smbd

Does it give you an output similar to this:
CODE
root     21420     1  0 06:38 ?        00:00:00 /usr/sbin/smbd -D


If not, the samba daemon is not running ...

If samba is running, then check that the directory you want to mount into is valid...does /mnt/win98 exist on the linux machine and does the user you are mounting from have permission to see into the directory.

If that wasn't the problem, make sure the share works OK on the Win98 machine. (I don't have a Win98 machine ... so I am doing this part from memory) From the Win98 machine open Windows Explorer {not internet explorer smile.gif } and look for Network Places or My Network. Double click that and find the name of the computer ... double click that and see if a share named hd exists on that machine.
-------------------------------------------------
If everything works so far, then I think the problem is probably in the /etc/smb.conf file on the linux machine...

Are the Win98 network Workgroup and the workgroup line (in /etc/smb.conf) set to the same name ... here is a copy of my workgroup line in /etc/samba.conf:

workgroup = HOME
Roint
Well, I tried all that, and nothing worked. Maybe I'll reinstall Samba later.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.