Help - Search - Members - Calendar
Full Version: X Video Troubles
Linuxhelp > Support > Technical Support
doctorzoidy
ok, so im running (attempting to) Redhat 9.0..
i used the command line install, as it choked on my video when trying the graphical...
it incorrectly probed my card (i have an ATI all-in-wonder, it came back as ATI Rage 128)... but it got my monitor correctly (princeton ultra90).

after correcting that in the last stages of startup, it did its reboot, and came into the x setup

this is where it started to suck.
the video had what i thought to be synch problems, there were 5 usable areas, with deadzones inbetween, and it flickered horribly... i've never seen anything like it.
i tried changing the resolution, color depth, when i brought it down to a 640x480 from 1600x1200, there were only two usable areas, so at least it shrunk down the dead zones too, and the flicker.
this wasnt helping, and i used to run WinXP at higher rates, so i put it back to 1600x1200, and then started editing the vertical synch.
normally my monitor (when powered up) displays the h-synch at around 31 and the v-synch at 60ish...

when x starts up, it went to h-synch 31ish and v-synch 30ish...

so i edited the v-synch and h-synch ranges down to a narrow 10KHz frequency
now its just gibberish, my monitor displays unable to synch...

so i dropped to console, edited my inittab so that it boots to console rather than graphics... but now i cant restart x or edit the x config to the original values...

so, my questions i guess are:

How do i edit the x configuration to the old synchs, or just let it probe again, when i cant start the program?

and

After its started, any suggestions about eliminating the desynch?

TIA
doctorzoidy
ok, so i found the config file, and edited the synch to the values i found at princetons page...
so now it will load up, but its still in that ugly multi deadzone and flicker look

any suggestions?
hughesjr
Which type of ATI all-in-wonder ... there is one for almost every ATI card... (ie ATI all-in-wonder 9800, ATI all-in-wonder 9700, ALL-IN-WONDER VE, etc...)

For the monitior, edit the file /etc/X11/XF86config and edit (or add) the lines in the Monitor section:

HorizSync 30.0 - 94.0
VertRefresh 50.0 - 160.0

(from http://www.princetongraphics.com/download/...et/Ultra90.pdf)
hughesjr
You can try the ATI proprietary drivers ... here is the check.sh file:

http://www2.ati.com/drivers/Check.sh

You will probably be able to download and install the 4.3.0 driver from HERE
doctorzoidy
sorry, its an ATI All-In-Wonder 128 AGP.

my synchs are set correctly, how do i run the .ch file to see what version of xfree i am using?

and how do i install new drivers (sorry, im overly familiar with Win, this is my first time installing linux)
hughesjr
it looks like rage 128 is the correct driver for the ATI All-In-Wonder 128 AGP...

edit the driver line in the Device section (of /etc/X11/XF86config) and try:

Driver "r128"
doctorzoidy
yep, already set for r128...
i wish i could send you a screenshot or a photo of what this thing is doing...
but to recap, i've got it set for r128, 1024x768, all in wonder 128 pro agp, 16mb memory...
the monitor is set to princeton ultra 90/90b, 30.0-94.0, 50.0-160.0
dpi 74 by 72...

everything tells me it should work, it just doesnt

thanks for your help thus far,
and thanks in advance for anything more
doctorzoidy
ok, here's something new... just on a whim i tried dropping the colors to 256 rather than "millions"... it flickers still, but i get the whole desktop image, no deadzones, no overlaps...

any advice anyone?
hughesjr
You might try the Experimental 10 driver HERE from the GATOS site.
doctorzoidy
ok, i d/led the file, expanded it as directed on the page, then it gets tricky...

i have no idea at all what it means by:
Please make sure to install _ALL_ of ati.2 binaries (if you compile _apply_, _make_ and _install_ patches (see ati_xv/README)). If you just install modules it will _not_ work. Installation process for 4.1.0 is identical (s/4.2.0/4.1.0).

and have no idea what README the directions refer to... the readme that was expanded from the tar.gz only has links for extended features, such as tv capture...

which, yeah, i'd like to capture tv again, but id rather have a whole desktop first smile.gif

so, do i not need to worry about the other stuff for now?
(i just registered with redhat network and am updating rpms and version dependencies, so i dont want to change res and logout at the moment)
hughesjr
It looks like the first thing you should do is back up the directory /usr/X11R6 (because the files in ATI-4.3.0-10.i386.tar.gz go there) like this:

cp /usr/X11R6 /usr/X11R6.bak

now copy the file ATI-4.3.0-10.i386.tar.gz to the /usr directory by doing the following command from the directory you downloaded it to:

cp ATI-4.3.0-10.i386.tar.gz /usr

then unzip and untar it with this command:

tar -xvzf ATI-4.3.0-10.i386.tar.gz
---------------------------
THIS IS ONLY REQUIRED IF NOT UNTARRED INTO /usr
(if you untar the file into /usr it will replace/update the X11R6 directory ... if you untared it into a different directory, you can copy the files into /usr/X11R6 like this ... change directories to your_untar_dir/X11R6 and do the command ls. You should see this output:

ATI.2.TIMESTAMP
lib
README.ati.2

Issue the command:

cp -R . /usr/X11R6

now just exit X and restart X (a reboot might be good)
---------------------------
note:
If the drivers don't work you can just do this command to go back to the old files:

rm -rf /usr/X11R6
cp -R /usr/X11R6.bak /usr/X11R6


(before you do a rm -rf /usr/X11R6, make sure the /usr/X11R6.bak directory is there!)
----------------------

I don't think you need the drm-kernel module (it seems to be for radeon only...)
doctorzoidy
well, thats pretty much what i did, excepting the whole backing up my directory (i know, too much speed, not enough steering wheel)...

and it hasnt seemed to change anything, but i only tooled with it for a few minutes before she yelled at me about doing more computer stuff on "our time"...

so, im going on vacation for a few weeks, and i guess it'll be waiting for me when i get back...

thanks for all the help, see you in a few weeks...
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.