Help - Search - Members - Calendar
Full Version: Serial Ata Controller Acts Weird...
Linuxhelp > Support > Technical Support
DjRedMar
Hi guys,

i am very new here at this forum, but just wanted to know something.

I've installed Debian and upgraded the kernel. The new kernel is 2.4.22 and i selected Sillicion valley (NEW) driver to be installed. This all just went fine no troubles.

this is my hardware
an onboard IDEController <-- on this one is my linux os installed
an Serial ATA Controller <-- is 4 an extra drive.

When i reboot with the new kernel it comes up till IDE devices
it finds my Serial ATA Controller first, so that's going to be hda.
This may NOT happen it should be another assigment like hde or something.

After that is loaded my own onboard IDE-controller comes ... IDE3 and IDE4 :S

I tried the option [ ] Boot off-board chipsets first but that did not work sad.gif
i installed grub but that screwed my system so i could reinstall :'(

who can help me out?!
wwtk
Disk drive device assignments come from the bios assignments, if your bios says the serial ata disk is your first disk, then linux sees it that way. If you use lilo to boot, you can change the drive mappings to anything you want. You may also be able to change settings in your bios to make the "regular" drives first.
DjRedMar
well it is an compaq :

but i can't put it somewhere because the controller has got his own bios.

But the problem is solved i tested it @ an test box at home... and in the real server it just worked as i wanted!

thanx alot 4 your help!

grtz Dj RedMar
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.