Help - Search - Members - Calendar
Full Version: Winfast Tv 2000 Xp Deluxe F
Linuxhelp > Support > Hardware Support
eb2e2
I followed "Corey's TV Tuner Guide" but after compiling kernel , on rebut dmesg doesn't show anything about bttv and that damn' tuner card.
Can you help me ?
Corey
You need to make sure that you insert the modules into your kernel. As root, issue the following command:

/sbin/modprobe -v bttv

Then you can go ahead and run 'dmesg' and check to see what it was auto-detected as.
eb2e2
Thanks !
It works !!!

dmesg says

i2c-core.o: i2c core module
i2c-algo-bit.o: i2c bit algorithm module
bttv: driver version 0.7.96 loaded
bttv: using 4 buffers with 2080k (8320k total) for capture
bttv: Host bridge is VIA Technologies, Inc. VT8367 [KT266]
bttv: Bt8xx card found (0).
bttv0: Bt878 (rev 17) at 00:0c.0, irq: 11, latency: 32, mmio: 0xdddfe000
bttv0: detected: Leadtek WinFast TV 2000 [card=34], PCI subsystem ID is 107d:6606
bttv0: using: BT878(Leadtek WinFast 2000/ W) [card=34,insmod option]
bttv0: gpio: en=00000000, out=00000000 in=00bff706 [init #1]
bttv0: gpio: en=00000000, out=00000000 in=00bff706 [init #1]
bttv0: gpio: en=00000000, out=00000000 in=00bff706 [init #2]
bttv0: gpio: en=00c33000, out=00000000 in=003cc706 [audio: extern]
bttv0: gpio: en=00c33000, out=00000000 in=003cc706 [muxsel]
i2c-algo-bit.o: Adapter: bt848 #0 scl: 1 sda: 1 -- testing...
i2c-algo-bit.o:1 scl: 1 sda: 0
i2c-algo-bit.o:2 scl: 1 sda: 1
i2c-algo-bit.o:3 scl: 0 sda: 1
i2c-algo-bit.o:4 scl: 1 sda: 1
i2c-algo-bit.o: bt848 #0 passed test.
i2c-core.o: adapter bt848 #0 registered as adapter 0.
bttv0: using tuner=5
bttv0: i2c: checking for MSP34xx @ 0x80... not found
bttv0: i2c: checking for TDA9875 @ 0xb0... not found
bttv0: i2c: checking for TDA7432 @ 0x8a... not found
i2c-core.o: driver i2c TV tuner driver registered.
tuner: probing bt848 #0 i2c adapter [id=0x10005]
tuner: chip found @ 0xc2
tuner: type set to 5 (Philips PAL_BG (FI1216 and compatibles))
bttv0: i2c attach [client=Philips PAL_BG (FI1216 and compa,ok]
i2c-core.o: client [Philips PAL_BG (FI1216 and compa] registered to adapter [bt848 #0](pos. 0).
bttv0: gpio: en=00c33000, out=00800000 in=003cc706 [audio: off]
bttv0: registered device video1
bttv0: registered device vbi0
bttv0: registered device radio0

I thought that bttv module will be automatically inserted. I suppose I have to insert it, for permanent use, with /etc/modules.conf , have I? Now I'll work for using the remote with lirc.
DjRedMar
QUOTE (eb2e2 @ Oct 9 2003, 03:44 PM)
Thanks !
It works !!!

dmesg says

i2c-core.o: i2c core module
i2c-algo-bit.o: i2c bit algorithm module
bttv: driver version 0.7.96 loaded
bttv: using 4 buffers with 2080k (8320k total) for capture
bttv: Host bridge is VIA Technologies, Inc. VT8367 [KT266]
bttv: Bt8xx card found (0).
bttv0: Bt878 (rev 17) at 00:0c.0, irq: 11, latency: 32, mmio: 0xdddfe000
bttv0: detected: Leadtek WinFast TV 2000 [card=34], PCI subsystem ID is 107d:6606
bttv0: using: BT878(Leadtek WinFast 2000/ W) [card=34,insmod option]
bttv0: gpio: en=00000000, out=00000000 in=00bff706 [init #1]
bttv0: gpio: en=00000000, out=00000000 in=00bff706 [init #1]
bttv0: gpio: en=00000000, out=00000000 in=00bff706 [init #2]
bttv0: gpio: en=00c33000, out=00000000 in=003cc706 [audio: extern]
bttv0: gpio: en=00c33000, out=00000000 in=003cc706 [muxsel]
i2c-algo-bit.o: Adapter: bt848 #0 scl: 1 sda: 1 -- testing...
i2c-algo-bit.o:1 scl: 1 sda: 0
i2c-algo-bit.o:2 scl: 1 sda: 1
i2c-algo-bit.o:3 scl: 0 sda: 1
i2c-algo-bit.o:4 scl: 1 sda: 1
i2c-algo-bit.o: bt848 #0 passed test.
i2c-core.o: adapter bt848 #0 registered as adapter 0.
bttv0: using tuner=5
bttv0: i2c: checking for MSP34xx @ 0x80... not found
bttv0: i2c: checking for TDA9875 @ 0xb0... not found
bttv0: i2c: checking for TDA7432 @ 0x8a... not found
i2c-core.o: driver i2c TV tuner driver registered.
tuner: probing bt848 #0 i2c adapter [id=0x10005]
tuner: chip found @ 0xc2
tuner: type set to 5 (Philips PAL_BG (FI1216 and compatibles))
bttv0: i2c attach [client=Philips PAL_BG (FI1216 and compa,ok]
i2c-core.o: client [Philips PAL_BG (FI1216 and compa] registered to adapter [bt848 #0](pos. 0).
bttv0: gpio: en=00c33000, out=00800000 in=003cc706 [audio: off]
bttv0: registered device video1
bttv0: registered device vbi0
bttv0: registered device radio0

I thought that bttv module will be automatically inserted. I suppose I have to insert it, for permanent use, with /etc/modules.conf , have I? Now I'll work for using the remote with lirc.

very nice that this worked! i have the same card and want it to use under linux! smile.gif thanx!!
Corey
Congrats, i'm glad that it worked.

If you want it to autoload on boot, you have to add it to your distro's autoload config. This varies between distributions, for example, on Debian it's /etc/modules and in gentoo it's /etc/modules.autoload . Please check with your distributions documentation to see what's right for you.


Out of curiosity, your tuner was supposed to be PAL right? Have you tried to watch TV yet, using tvtime or something? Did everything turn out okay? As well, i noticed that it setup your tv under /dev/video1 , do you have a webcam or something under /dev/video0?
hughesjr
I currently have a Hauppauge WinTV card that uses the BT878 as well. I use it with MythTV. (BTW, I highly recommend MythTV). My Hauppauge card doesn't have a remote, so I am probably going to replace it.

I have a question concerning the output of this card ... on my Hauppauge if there is a lot of white in the picture it seems to fade (I noticed this in both Windows and Linux so it must be the card). Does this card have a similar problem ... and overall how is the output of the card?
Corey
Yeah, I use mythtv as well, but for different reasons. Mythtv is great for scheduled recording, watching movies, dvd's, music, etc. As for actual live tv, i don't like the delays that Mythtv has. It's totally understandable because they allow for pauseing live tv, and stuff. I highly recommend TVtime for regular tv watching.

I haven't noticed any visual problems with this card at all. All in all, i'd have to say that it has performed up to my expectations, and I've never had a problem with it (other then the remote control issue which i was able to fix, and is described in my guide). If you were to purcahse another card, I would recommend this one. The remote is also quite snazzy, and thanks to a few extra buttons on there (red, green, yellow and blue), i can program 'modes' easier. So, when i hit red, it goes into tvtime mode and controls that. when i hit green, it goes to mythtv and controls that. Same with xmms and mplayer. If you want, read up on the reviews on tweak3d.net and other sites.
eb2e2
QUOTE (duende @ Oct 9 2003, 10:33 PM)
Congrats, i'm glad that it worked.

If you want it to autoload on boot, you have to add it to your distro's autoload config. This varies between distributions, for example, on Debian it's /etc/modules and in gentoo it's /etc/modules.autoload . Please check with your distributions documentation to see what's right for you.


Out of curiosity, your tuner was supposed to be PAL right? Have you tried to watch TV yet, using tvtime or something? Did everything turn out okay? As well, i noticed that it setup your tv under /dev/video1 , do you have a webcam or something under /dev/video0?

I use RedHat 9 I don't know where I have to find autoload config. In /etc/modules.conf I have

alias eth0 8139too
#alias char-major-81 bttv
alias usb-controller usb-uhci
alias sound-slot-0 via82cxxx_audio
post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null 2>&1 || :
pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null 2>&1 || :
#i2c
alias char-major-89 ic2-dev
options i2c-core i2c_debug=1
options i2c-algo-bit bit_test=1
#bttv
alias char-major-81 videodev
alias char-major-81-0 bttv
alias char-major-81-1 tvaudio
alias char-major-81-64 radio
alias char-major-81-192 vtx
alias char-major-81-224 vbi
options bttv pll=1 radio=1 card=34 tuner=5 bttv_gpio=1
options gbuffers=4
options tuner type=5
options tuner debug=1
alias tvcard0 bttv

How I can autoload bttv module on boot ?
I have a webcam or /dev/video0

" Linux video capture interface: v1.00
pwc Philips PCA645/646 + PCVC675/680/690 + PCVC730/740/750 webcam module version 8.8 loaded.
pwc Also supports the Askey VC010, Logitech Quickcam 3000 Pro, Samsung MPC-C10 and MPC-C30,
pwc the Creative WebCam 5, SOTEC Afina Eye and Visionite VCS-UC300 and VCS-UM100.
usb.c: registered new driver Philips webcam
pwc Creative Labs Webcam 5 detected.
pwc Registered as /dev/video0.

I do watch TV and is OK because I'm in Europe and anything TV is here PAL... ( except France an Russia )
On weekend i'll "work" with the remote and lirc. i hope i"ll managed.
hughesjr
One thing that I see is that your gbuffers line needs to be like this:

options bttv gbuffers=4

I'm not positive (I have a different tv card), but I would try remarking out these lines:

#alias char-major-81 videodev
#alias char-major-81-0 bttv

and adding this line:

alias char-major-81 bttv
-------------------------
if all else fails, you can add the below line to your /etc/rc.local file:

/sbin/modprobe -v bttv
hughesjr
I just installed tvtime and I think it is a very good program. The picture quality is great. I agree that it is a great program for watching TV only...things like sports/news tickers look very good and it uses much less CPU than mythtv (since it is not recording the live stream to allow pausing / rewind capability)...

I am used to the channel info and pause features of mythtv too though!!!!

I would highly recommend tvtime to anyone for watching TV...and the installation on RedHat 9.0 (with apt-get and apt.sw.be as an apt source) was a simple:

apt-get install tvtime

The rpm that was installed (tvtime-0.9.10-1.dag.rh90.i386.rpm) was the same one available for download at the tvtime site and I'm sure it installs just as easily when downloading it from there and using:

rpm -Uvh tvtime-0.9.10-1.dag.rh90.i386.rpm
Corey
Yeah, I came accross TVtime one day looking for a deinterlacer plugin for Xawtv, and I have never gone back to Xawtv, not even for fbtv (TVtime has built in framebuffer support). The picture quality would be about 10 times better because in Mythtv, you see a compressed stream using mpeg4 or RTjpeg (i think). I know, for myself, watching hockey games looks perfect in tvtime.
eb2e2
The remote work too . I have to write this lines on /etc/rc.d/rc.local

/sbin/modprobe bttv
/sbin/modprobe lirc_gpio
/sbin/modprobe lirc_dev
/etc/rc.d/init.d/lirc.redhat start
/etc/rc.d/init.d/lircs -c


Is this th right method to do such things ?

I installed tvtime . I like how it works. tvtime-scanner did find all my channels indeed.

tongue.gif
Corey
Well, that is one way of getting the modules to probe off boot up, but i'm sure Redhat has a file somewhere that you can list what modules need to be probed on bootup. As I stated earlier, this is included in Debian and Gentoo at least, it must be in Redhat as well.
eb2e2
I like tvtime, but something is "strange"
When I use "Custom Frequency Table" with input tv norm = PAL, the colours are not natural, they are lke withaout saturation
When I use "Europe Frequency Table" with input tv norm = PAL, the colours are natural, are OK.
why ?
Corey
I'm not too sure why that's happening, i've never looked at any other frequency lists other then US Cable and the famed Canada-Cable. Perhaps the Custom Frequency Table isn't correct for your area? If you feel that this is a bug, then you should submit a bug report to the TVtime developers (www.tvtime.net).
josefen
Hello fellows!

I'm running Gentoo and the v2.4.20-gentoo-r7 kernel. Ever since I left Red Hat for Gentoo i'we missed my Tv 2000 XP card...
Then I found the nice guide to install... But.
I can't find:
Multimedia Devices -> Video For Linux -> BT848 Video For Linux (M) nore
Sound -> TV Card (bt848) mixer support (M) in my menuconfig program...

Do I have to have something else highlighted first?
josefen
heh, never mind - i found it smile.gif

You have to highlight these little fellas first
# Character Devices -> I2C Support -> I2C Support (M)
# Character Devices -> I2C Support -> I2C bit-banging interfaces (M)

Thanks anyway
Corey
Let us know if you have it working okay, and if you have any suggestions for the guide, let me know.
josefen
Heh, it's not working with TVtime...
It depends on my realtime clock...
rtctimer: Cannot open /dev/rtc: No such file or directory
rtctimer: Cannot open /dev/misc/rtc: No such file or directory
So i have to figure out a way to solve that.... Can you help with that... it's a little off topic. but smile.gif

Perhaps you should just note that you have to highlight these
# Character Devices -> I2C Support -> I2C Support (M)
# Character Devices -> I2C Support -> I2C bit-banging interfaces (M)
before you highlight the other....
Corey
You need to have root permissions in order to use the real time clock. This can be done one of two ways, you can either:

a) Run tvtime as root, which is not very practical, or...

b) make tvtime setuid with "chmod u+s /usr/bin/tvtime". This will allow a regular user to run tvtime with root permissions. Don't worry, tvtime drops root permissions as soon as it gets access to what it needs, which is pretty quickly in the code.
vektor
QUOTE (josefen @ Oct 15 2003, 01:08 PM)
Heh, it's not working with TVtime...
It depends on my realtime clock...
rtctimer: Cannot open /dev/rtc: No such file or directory
rtctimer: Cannot open /dev/misc/rtc: No such file or directory

The error it got was 'No such file or directory'. That means that your first problem is that you do not have a /dev/rtc device file. If you are not using devfs, you should probably run 'cd /dev; ./MAKEDEV rtc'.

The RTC device is not a _dependency_ in tvtime, we work without it, but video will not be as smooth as it should be at high framerate. So, it's just a decrease in quality. smile.gif You can enable the RTC device in the 'Character Devices' section of make menuconfig, 'Enable Real Time Clock Device' I think is what it says.
josefen
Okej guys! I made it - the card is now running fine!

But after closing the app the sound remains...
josefen
Never mind smile.gif I fixed it smile.gif

Thanks for all help!
phote
I broke my Windows addiction this last summer and have been happily running Redhat 9.0 on my entertainment PC, watching TV with my Leadtek Winfast TV2000XP Deluxe with TvTime and watching DVD's with Ogle.

Until coming across "Corey's TV Tuner Guide," I didn't know that I could get the remote to work under Linux too. As I've been using TvTime for a few months now, the bttv driver is obviously working fine. However, I'm have trouble compiling LIRC to get the remote working. I downoaded the modified LIRC package from http://www.thegoodtimes.ca/winfast/files/l...0.6.6-cq.tar.gz and followed the instructions in the README-WINFAST file. Upon issuing the "make" command, I get the following error message:

cd .
&& CONFIG_FILES= CONFIG_HEADERS=config.h
/bin/sh ./config.status
config.status: creating config.h
config.status: config.h is unchanged
make all-recursive
make[1]: Entering directory `/usr/src/lirc-0.6.6-cq'
Making all in drivers
make[2]: Entering directory `/usr/src/lirc-0.6.6-cq/drivers'
Making all in lirc_dev
make[3]: Entering directory `/usr/src/lirc-0.6.6-cq/drivers/lirc_dev'
DIR=`pwd`; (cd /usr/src/linux-2.4.20-8/; make SUBDIRS=$DIR obj-m=lirc_dev.o modules)
/usr/src/linux-2.4.20-8/scripts/pathdown.sh: line 4: TOPDIR: parameter null or not set
make[4]: Entering directory `/usr/src/linux-2.4.20-8'
make[4]: *** No rule to make target `lirc_dev.o', needed by `modules'. Stop.
make[4]: Leaving directory `/usr/src/linux-2.4.20-8'
make[3]: *** [lirc_dev.o] Error 2
make[3]: Leaving directory `/usr/src/lirc-0.6.6-cq/drivers/lirc_dev'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/usr/src/lirc-0.6.6-cq/drivers'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/src/lirc-0.6.6-cq'
make: *** [all] Error 2

I don't often install packages from source, so I don't really know what's going on here. Can you let me know what I need to do to get the package installed correctly? Thanks.
Corey
That's odd. Out of curiosity, do you have the kernel source tree stored in /usr/src/kernel? It looks like the install script is looking there for some kernel headers.
phote
I have the kernel source tree stored in /usr/src/linux-2.4.20-8.

By the absence of binaries, it also looks like it has never been configured or compiled. Would that make a difference?
hughesjr
go to /usr/src/linux-2.4.20-8 and run the command:

make mrproper

Then copy the /boot/config-kernel file to /usr/src/linux-2.4.20-8/.config ...

then from within /usr/src/linux-2.4.20-8/ run the following commands;

make oldconfig
make dep

That should setup all the headers so you can compile stuff.

Also these commands:

cd /usr/src
ln -s linux-2.4.20-8 linux

Will create a /usr/src/linux ... which is where most programs that compile kernel modules look by default ...
phote
That worked. Lirc compiled and installed without errors, but it doesn't seem to work yet. When I run lircd in nodaemon mode I get the message:

QUOTE
lircd 0.6.6: lircd(winfast_tv2000) ready


However, when I start irw to test the remote I get:

QUOTE
lircd 0.6.6: accepted new client on /dev/lircd
lircd 0.6.6: could not open /dev/lirc
lircd 0.6.6: default_init(): No such device
lircd 0.6.6: caught signal
Terminated


When I do a "ls" in /dev, /dev/lirc is in the black block with yellow text format that I infer means inactive. What needs to happen for me to get the lirc daemon working correctly?
Corey
It's possible that this may be a permissions problem, have you tried to run irw as root? If it works with root, then check the permissions on /dev/lircd.
phote
With some poking around, I figured it out.

FYI: It turns out that "make install" did not actually install the module because it said the module
QUOTE
/lib/modules/2.4.20-8/misc/lirc_dev.o was compiled for kernel version 2.4.20-8custom

That must be because I went through the process outlined by hughesjr above. "Well that's silly," I thought, because I didn't change anything about the kernel and didn't change the configuration file before compiling the kernel modules. So I forced the module in with "insmod -f lirc_gpio". (I also changed the permissions on /dev/lircd and /dev/lirc to rw-rw-rw, but I don't know if that did anything important.) Then I ran lircd and irw and all the buttons on the remote were working correctly. Now I just have to tweak the ~/.lircrc file.

Thanks for your help.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.