Help - Search - Members - Calendar
Full Version: Cdrom Woes
Linuxhelp > Support > Technical Support
Nzyme
Hi,

I'm a linux newbie (new as in 4 days old), so i need some hand-holding help. Here's my problem:

when i first installed Mandrake 9.1, i had no audio at all (no mp3s, no cds). i messed around in mandrake control (i'm using KDE, btw) and reconfigured (i think) the driver for my soundcard and i was able to listen to mp3s. However, if i try to play an audio cd using a basic program like KsCD, it doesn't even recognize the audio CD. I can access the drive to transfer data files no problem. I know the drive works because i was running WinXP (more like LoseXP) and it worked fine. The drive is an older Plexwriter (12/10/32A).

the drive was automatically mounted (i don't really understand what that means). if i put an audio CD in and try to just access the files, i get the following error:

Could not enter directory /mnt/cdrom

so i can't even view the contents of the CD - wierd!

some of the postings say that you don't have to mount cd drives, but i don't really know what that means, so i don't know how to unmount a drive either.

thanks in advance for your help!

Nzyme
hughesjr
Do you have the audio cable connected between the CDROM and the sound card?
Nzyme
yes. as i mentioned in my original question, i've been running windows on this machine for 2 years and have never had a problem. i haven't touched the hardware since i installed linux..
hughesjr
Windows Media Player 9 can play audio from a CD without an audio cable connected to the sound card .... Linux can not (at least I can't make it) ... so it is very possible to play Audio CD's in Windows XP and not be able to play the same CD in Linux. In fact, PC's that are built with Windows XP installation in mind may not have a cable connecting the CD-Rom to the soundcard....and therfore will not play audio CD's if Linux is installed.
Nzyme
that's interesting that WMP can play CD's w/o the connection...idiot proofing, i guess. however, i rarely used WMP, and i built the system myself, so i know that i did it correctly. despite my confidence in my comp-building abilty, i opened 'er up and checked. the CDROM drive is indeed connected to the sound card. could it be a driver problem?

remember, i can't even look at the files on an audio CD, but i can look at the files on a data CD. it's got to have something to do with the file format or something...

i tried both home-burnt and store-bought audio CDs, and the result is the same for both.

it's really strange to me that i can't even access the files...
hughesjr
Linux doesn't mount AUDIO CDs the same way it mounts DATA CDs. My CD/DVD player works fine, but I can't see any files on audio CDs either.

It is possible that the driver for your sound card doesn't recognize your CD in line .... try adjusting all adjustments on the mixer to the middle position and see if you get sound when playing the CD.

My CD player is controlled by the phin slider on the Volume control, even though it is plugged into the CD in jack on the sound card.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.