Help - Search - Members - Calendar
Full Version: Neebie Linux Help!
Linuxhelp > Support > Technical Support
das7282
I was hoping someone here could help me; I'm an almost complete newbie when it comes to Linux and some how I screwed up my installation. I need to know how I can fix it.

Here's the problem. I'm running Suse 8.2 Professional and I was having problems running a game (UT2003) so I went poking around (yes, I was poking ohmy.gif ) in the video card settings. The video card is an nVidia Geforce 3 Ti200 and (supposedly) I had the latest (nVidia 1.0-4496) drivers installed. I noticed that "3D acceleration" wasn't enabled so I clicked the box to enable it. When I clicked "Finish" it gave me an error say the there was a mismatch. I wish I could remember exactly what it said but it said something about 24bit..... 16bit (I was running it in 24bit mode). So I figured 3D acceleration might need to run in 16bit mode so I changed it to 16bit mode. When I clicked "Finalize" it said the changes wouldn't take effect until the GUI was restarted, so I restarted the computer.

That's when the problem started, I have lost the GUI!!! When it starts up, my screen flashes a couple of times and then it goes straight to command line.

I have put way too much time into this installation to lose it. (I have several programs installed, got Folding@Home working on it and I have over 1600 MP3s transfer over to it!) I will try anything to not have to reinstall everything and start over again! Can someone please help?!

PS
Sorry for my newbie ness. tongue.gif

DAS
Corey
Luckily, SuSE has a console version of their configuration program, so you can get back into it by running YaST2. Go back into your configuration settings for X, make sure that you have the correct monitor set (when in doubt, consult your monitor manual and manually enter in your Horizontal Sync range and Vertical Refresh rate. Make sure that your resolutions aren't out of whack (to be safe, include 1024x768, 800x600 and 640x480). Double check to make sure that you have the 3D acceleration set.

If you have no luck using the configuration program, then we may have to get down and dirty with the /etc/X11/XF86Config file, and edit it manually. Here is a copy of my configuration using a nVidia geforce card and a 17" monitor:

A few notes: I'm using a usb scroll mouse. Make sure you don't have DRI and GLCore listed in your Module section, and remote the DRI section.

QUOTE
Section "Module"
    Load        "dbe"  # Double buffer extension
    SubSection  "extmod"
      Option    "omit xfree86-dga"  # don't initialise the DGA extension
    EndSubSection
    Load        "type1"
    Load        "speedo"
    Load      "glx"
EndSection

Section "Files"
    RgbPath "/usr/X11R6/lib/X11/rgb"
    FontPath  "/usr/X11R6/lib/X11/fonts/local/"
    FontPath  "/usr/X11R6/lib/X11/fonts/misc/"
    FontPath  "/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
    FontPath  "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
    FontPath  "/usr/X11R6/lib/X11/fonts/Speedo/"
    FontPath  "/usr/X11R6/lib/X11/fonts/Type1/"
#    FontPath  "/usr/X11R6/lib/X11/fonts/TrueType/"
#    FontPath  "/usr/X11R6/lib/X11/fonts/freefont/"
    FontPath  "/usr/X11R6/lib/X11/fonts/75dpi/"
    FontPath  "/usr/X11R6/lib/X11/fonts/100dpi/"
#    ModulePath "/usr/X11R6/lib/modules"

EndSection

Section "ServerFlags"
#    Option "NoTrapSignals"
#    Option "DontVTSwitch"
#    Option "DontZap"
#    Option "Dont Zoom"
#    Option "DisableVidModeExtension"
#    Option "AllowNonLocalXvidtune"
#    Option "DisableModInDev"
#    Option "AllowNonLocalModInDev"
EndSection

Section "InputDevice"
    Identifier "Keyboard1"
    Driver "Keyboard"
    Option "AutoRepeat" "500 30"
    Option "XkbRules" "xfree86"
    Option "XkbModel" "pc104"
    Option "XkbLayout" "us"
    Option "XkbVariant" "us"
EndSection


Section "InputDevice"
    Identifier "Mouse1"
    Driver "mouse"
    Option "Protocol"    "ImPS/2"
    Option "Device"      "/dev/input/mice"
    Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
    Identifier  "komodo"
    HorizSync  31.5 - 79.0
    VertRefresh 40-150
EndSection

Section "Device"
    Identifier  "geforce"
    Driver      "nvidia"
    Option "NoLogo" "1"
EndSection

Section "Screen"
    Identifier  "Screen 1"
    Device      "geforce"
    Monitor    "komodo"
    DefaultDepth 24

    Subsection "Display"
        Depth      24
        Modes      "1280x1024" "1024x768" "800x600" "640x480"
        ViewPort    0 0
    EndSubsection
EndSection

Section "ServerLayout"
    Identifier  "Simple Layout"
    Screen "Screen 1"
    InputDevice "Mouse1" "CorePointer"
    InputDevice "Keyboard1" "CoreKeyboard"
EndSection
das7282
QUOTE (duende @ Sep 21 2003, 01:57 PM)
Luckily, SuSE has a console version of their configuration program, so you can get back into it by running YaST2.  Go back into your configuration settings for X, make sure that you have the correct monitor set (when in doubt, consult your monitor manual and manually enter in your Horizontal Sync range and Vertical Refresh rate.  Make sure that your resolutions aren't out of whack (to be safe, include 1024x768, 800x600 and 640x480).  Double check to make sure that you have the 3D acceleration set.

If you have no luck using the configuration program, then we may have to get down and dirty with the /etc/X11/XF86Config file, and edit it manually.  Here is a copy of my configuration using a nVidia geforce card and a 17" monitor:

A few notes: I'm using a usb scroll mouse.  Make sure you don't have DRI and GLCore listed in your Module section, and remote the DRI section.


Thanks for the info, I appreciate it. But I am so new to Linux, there are a few things you explained that I still don't quit understand.

This is what I'm doing...

1) I log in as root at the command line and I type "yast2". Yast2 opens and I go to the "hardware" option and then the "Graphics card and monitor" option. There it gives me five choices, "Text mode only", "Graphical...", "Change", "Cancel" and "Accept". The x is in "Graphical..." and when I select the option to change, my screen goes blank for a few seconds and then... nothing. It goes back to those five options without letting me change anything.

2) But when I'm in the Graphics card and monitor section it tells me this...

Card: NVidia GeForce 3 Ti 200 (nvidia)
Monitor: Unknown [ 15-61 kHz / 30-87 Hz]
Resolution: 1024x768
Color depth: 16bit
3D Acceleration: Enabled


Incidentally, the monitor is a 15" LCD that has a native resolution of 1024x768@60Hz and that's what I set it at when I installed Suse. How it changed to "Unknown", I'm not sure.

3) You said to see if I could edit my "XF86Config" file but this is where my lack of Linux experience is really evident. Because I'm not sure how to do that in command line mode. I tried navigating over to it by typing "/etc/X11/XF86Config" but it told me I didn't have permission (even when I was logged in as root).

4) Now this next thing might give the most info on the problem but it's still Greek to me. When I try to manually start the GUI by entering "startx" I get the following error message...

QUOTE
XFree86 Version 4.2.0 / X Window System
(protocol Version 11, revision 0, vendor release 6600)
Release Date: 23 January 2002
Build Operating System: SuSE Linux [ELF] SuSE
Module Loader present
(==) Loge File: "/var/log/XFree86.0.log", Time: Sun Sep 21 17:48:33 2003
(==) Using Config file: "/etc/X11/XF86Config"
NV: could not open control device /dev/nvidiactl (No such device)
(EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module!
(EE) NVIDIA(0): *** ABORTING ***
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found

XIO: fatal IO error 104 (Connection reset by peer) on X server ":0.0"
after 0 request (0 known processed) with 0 events remaining.


Do any of that make any sense to you?

Thanks in advance,

DAS
Corey
From what I can tell, it doesn't look like the official nvidia drivers were install correctly. When you're logged in as root, type:

QUOTE
lsmod | grep nvidia


if that gives you nothing back, then type the following:

QUOTE
modprobe -v nvidia


if this tells you that "Modprobe: Cannot locate module nvidia" then you don't have the drivers installed.

I can't give much detail because i don't have suse installed, but double check in yast to make sure that 3d acceleration installed. As well, i believe that Yast2 gives you some info about installing the nVidia drivers.
das7282
Hmmm???

Well, typing "lsmod | grep nvidia" didn't do anything. But typing "modprobe -v nvidia" gave me back the following info...

QUOTE
/sbin/insmod /lib/modules/2.4.19-4GB/kernel/drivers/video/nvidia.o
Using /lib/modules/2.4.19-4GB/kernel/drivers/video/nvidia.o
Symbol version prefix ''
/lib/modules/2.4.19-4GB/kernel/drivers/video/nvidia.o: unresolved symbol __pollwait
/lib/modules/2.4.19-4GB/kernel/drivers/video/nvidia.o:
Hint: You are trying to load a module without a GPL compatible license
and it has unresolved symbols. Contact the module supplier for
assistance, only they can help you.

/lib/modules/2.4.19-4GB/kernel/drivers/video/nvidia.o: insmod /lib/modules/2.4.19-4GB/kernel/drivers/video/nvidia.o failed
/lib/modules/2.4.19-4GB/kernel/drivers/video/nvidia.o insmod nvidia failed


I still have the nVidia drivers in a directory in my user account. But they are RPMs and I don't know how to install them without YaST2. Will reinstalling them help? How do you install RPMs from the command line?

DAS
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.