Help - Search - Members - Calendar
Full Version: Weird Lilo Behavior...
Linuxhelp > Support > Technical Support
Tayl
I am trying to install Slack 9 so it dual-boots with Windows XP, and the installation went fine. Then, after I rebooted, Lilo loads up, and it has the Slackware and Windows option, so I select Slackware....it says "Loading Slackware......" and then...blank. Confused, I tried again. Same behavior. Getting kind of scared, I tried the Windows option, and THAT booted, so at least I have something. Also, I tried using my Linux bootdisk, and THAT works. Works great. Just using Lilo doesn't let it boot.

So I did some searching, and found that Lilo has trouble working if the partition is a ways back in the disk...which I did. My main partition is Windows, which takes up 25 gigs of my 40 gig hard drive. Then Slack9 takes up the last 15 gigs. So I tried everything it said on the stuff I found through google, and still nothing. I have version 22.4.1 of Lilo, which is supposed to support the lba32 option and let it work.

I'll add my lilo.conf file at the end, so you can read it. Now, just a few minutes ago, I booted into Slackware, and let it run...I noticed that my CPU light on the front of my case was flashing, like Linux was actually loading. Intrigued, I waited until it stopped and typed "root" and then my root password. It flashes for a second, as if responding to my input. I then tried "reboot", and lo and behold, it rebooted! So I guess that it IS booting correctly, but just not displaying it to my screen? Also, after it rebooted, I selected Slackware again, and this time manually restarted it in the middle of the apparent boot-up process. I then used my bootdisk to get into the Slack partition, and while booting, said that the "partition was uncorrectly unmounted and had to be checked" or whatever that error message is when you don't shut down properly. So...it WAS loading? I don't know. I set the option in lilo to just do normal VGA, none of the extra stuff, so....

Here is my lilo.conf file:

# LILO configuration file
# generated by 'liloconfig'
#
# Start LILO global section
boot = /dev/hda
#compact # faster, but won't work on all systems.
prompt
timeout = 300
lba32
# VESA framebuffer console @ 1024x768x256
#vga = 773
# Normal VGA console
vga = normal
# VESA framebuffer console @ 1024x768x64k
# vga=791
# VESA framebuffer console @ 1024x768x32k
# vga=790
# VESA framebuffer console @ 1024x768x256
# vga=773
# VESA framebuffer console @ 800x600x64k
# vga=788
# VESA framebuffer console @ 800x600x32k
# vga=787
# VESA framebuffer console @ 800x600x256
# vga=771
# VESA framebuffer console @ 640x480x64k
# vga=785
# VESA framebuffer console @ 640x480x32k
# vga=784
# VESA framebuffer console @ 640x480x256
# vga=769
# ramdisk = 0 # paranoia setting
# End LILO global section
# Linux bootable partition config begins
image = /boot/vmlinuz
root = /dev/hda5
label = Slackware
read-only # Non-UMSDOS filesystems should be mounted read-only for checking
# Linux bootable partition config ends
# DOS bootable partition config begins
other = /dev/hda1
label = Windoze
table = /dev/hda
# DOS bootable partition config ends

All of the partition targets are right....any suggestions? I'm stumped. unsure.gif
Joey
I would remove all the vga crap and try again.

Here's a copy of my lilo.conf file (Red Hat 9)

CODE
prompt
timeout=50
default=linux
boot=/dev/hda
map=/boot/map
install=/boot/boot.b
lba32

image=/boot/vmlinuz-2.4.20-20.9
       label=linux
       append="root=/dev/hda6"
       read-only
       initrd=/boot/initrd-2.4.20-20.9.img

image=/boot/vmlinuz-2.4.20-19.9
       label=linux.old
       append="root=/dev/hda6"
       read-only
       initrd=/boot/initrd-2.4.20-19.9.img
hughesjr
It looks like your Linux is booting .... just that you can't see it!

vga=normal should boot up in non VESA mode, but just in case, remove the vga line all together.

Are you loading into a GUI mode or Character Based mode? .... what is the last thing that is printed before it goes blank?
Tayl
Alright, I figured it out. I didn't know I needd to run /sbin/lilo to load my lilo.conf changes. dry.gif

Oh, well. It works now. Although I still can't use the framebuffer versions. I can only use the vga=normal option. Any ideas on why I can't boot using the framebuffer options? Oh, I am booting into the text mode, not into a GUI. And if I use framebuffers, I get the same problem: It seeming to boot, but not being able to see anything. Any suggestions?

P.S.- Oh, and I am now using Gnome, so my video drivers work fine. Just so you know.
hughesjr
Some cards have problems using FrameBuffers ... I can't use framebuffers in console mode because it causes the nvidia driver's (version 4496) glx module not to work properly. glx is used for 3D games and some video applications ...

I have this problem using the 2.4.20, 2.4.21, or 2.4.22 kernel and the nvidia drivers provided by nvidia.com of RedHat, Mandrake and SUSE.

If I use the standard nv driver from the kernel, everything work ... but I have no glx or 3D graphics....

So, I just use the 640x480 mode on my console....
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.