Help - Search - Members - Calendar
Full Version: Please Help; Monitor Disappears
Linuxhelp > Support > Technical Support
cagey cretin
I have a problem that has plagued me for the past two years: I haven't been able to install Linux.

I have 3 CD-set ISOs for Madrake 9_1 and Redhat 9; both eyield the same result (after the install process).

After the initial re-boot, my screen goes dead. As if it has powered
down. All my hardware meets with redhats HCL seal of approval, and was found by the OS as it was installing. I actually made it through the install process of all the OSes I tried. Upon re-boot, after listing all
services at start up, my monitor goes blank. All the tests during
install to see if the settings worked, did in fact work.

The monitor goes into sleep mode, by appearances.

Someone on another forum suggested trying another monitor. I did; I still fail to get Linux up and running.

Over the last two years I have used these books:

* Linux Bible (Hungry Minds)
* Building a Linux Internet Server (New Riders)
* RHCE Certification Study Guide (Osbourne/Syngress)
* Mastering RedHat 6.0 (Sybex)
* Redhat 9 Documentation PDF
* Redhat 7.1 Documentation PDF
* Mandrake 9.1 Documentation PDF
* Mandrake 7 Documentation PDF

Let me get this out now:

I have shit for brains, I don't know what I am doing, etc.

I would still appreciate any pointers/thoughts.

Joe Wilk
I feel your pain. In fact I just recently posted the same problem on another forum not but maybe 2 hours prior to this post. Your not alone and I will be sure to let you know if I recieve any information that may fix this problem.

One thing I noticed is while the screen is black, I cannot access my monitor's on-screen options. It's as if the resolution or something is jacked up.
cagey cretin
What a treat, eh?

I had posted this problem on another board, but was told to RTFM, you must be an idiot, your hardware is BS, etc. I hope someone can point us in the right direction here...


Joe Wilk
Can you give us a little more details on the type of hardware you have in the machine? (makes/models etc).

Did you configure X during the install? Did it configure it fine? Perhaps its the refresh rate or resoution that is set too high.

Maybe this post will help -
cagey cretin
Thank you helping Joey.

Diplsay Adapter: Radeon
Monitor: Dell D1025 TM
ATA 100 HD, 40 GB Maxtor
Advansyc SCSI adapter (R/RW CD Only)
Standard Serial Keyboard
Serial PS/2 Wheel Mouse

All devices were found in the configuration. I took the default settings they provided for the monitor, which do fall in the specs for the monitor. I will try to install with lower resolution and refresh rate.

Thank you,

Joe Wilk
When linux loads and the monitor goes dead try holding down the control and alt keys and then pressing the backspace key. This should kill the X server and dump you into console. You can then edit the XFree86 config file without having to reinstall.
I'm running AMD 850 NVIDIA GForce FX 5200. I realized that during installation I picked my video card out of a list rather that leaving it at the generic VESA driver. I found a post that was interesting..


I recently bought a Sony VAIO GRT170 notebook computer and I'm trying to
install RedHat Linux 9 alongside Windows XP. I'm pretty sure the
dual-booting works properly, since the GRUB bootloader comes up at startup
like it's supposed to, but when I choose Linux, I get a blank screen (after
all the intialization commands). From what I've read so far, I think this is
because of the video card (NVIDIA GeForce4 FX Go 5600, 64MB); during
installation, instead of leaving the generic VESA driver selected, stupid me
went through the list and chose the one that most closely matched. My
question is: how do I fix this without completely redoing the installation?
I downloaded the updated Linux drivers from NVIDIA's website, but I have no
idea what to do with them. Since I can't even really start Linux at all, I
have no idea what to do. I'm a complete newbie, so step-by-steb help would
be very much appreciated.



You can boot to runlevel 3 (a character based startup) and then edit your
/etc/XF86Config file to properly set the video information.

If you're not sure how to edit files in redhat character based mode, I
recommend nano ... it was probably installed ... and it is fairly easy to

When you load nano it will have a menu with commands, they will look like

^G Get Help ^O WriteOut ^X Exit

The ^ means use the Ctrl key ... so Ctrl-o will open the write out (save the
file) option then Ctrl-x will exit....

Here is how to boot to runlevel 3....
1. Start the PC ... when you get to GRUB, press the e key to go to edit
2. Find the Kernel line ... it will look something like this:

kernel /vmlinuz-2.4.20-18.9smp ro root=LABEL=/

3. Select this line using the Arrow Keys and with the line selected, press e
to edit the line.

4. Move to the end of the line, and add a space and 3....then press enter In
my line from above it would now look like this:

kernel /vmlinuz-2.4.20-18.9smp ro root=LABEL=/ 3

5. press b to boot.

You should end up at a character based login...login as the root user, using
the password you supplied in the installation.
Once logged in, edit the file /etc/X11/XF86Config ... if you don't have a
console based editor that you normally use, I recommend you first try nano
... see instructions above ... to edit with nano, issue the following

nano -w /etc/X11/XF86Config

Use the Arrow Keys to find the video card section ... in RedHat 9, that
section should look similar to this:

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "Videocard vendor"
BoardName "NVIDIA GeForce 2 MX (generic)"
VideoRam 65536

Change the driver line to:

Driver "nv"

(nv should be the standard driver for Nvidia Cards)

then use Ctrl-o to write the file ... then Ctrl-x to exit ...

use the command reboot to restart the PC ...

The RedHat installer has a test button to test the GUI display ... you
should always test the mode you want to boot to during the install....

As a general rule ... I never set my installs to boot to graphical mode, but
to boot to text mode. For the first boot, log in as root in text mode. Then
type startx ... if you have problems, use the keys Alt-Ctrl-Backspace to
exit X-windows and then edit the /etc/X11/XF86Config file ... make
adjustments ... and when it's right, then edit the file (for RedHat)
/etc/inittab and find the runlevel line:


and change the 3 to a 5 to boot to runlevel 5 (graphical mode)....actually,
I never boot to runlevel 5 ... I just login as who I want and type startx...
cagey cretin
QUOTE (Joey @ Sep 10 2003, 09:02 AM)
When linux loads and the monitor goes dead try holding down the control and alt keys and then pressing the backspace key. This should kill the X server and dump you into console. You can then edit the XFree86 config file without having to reinstall.

Well, I have tried to install several more times, as the problem continues, no matter what refresh rates I enter. By the way, the defaults listed are within the specs of my monitor.

Joey: ctrl-alt-backspace doesn't do anything, so I went to kk19115's post.

Now, I am a newbie, but why should I have to alter the boot line for a first boot after the OS install utility just set everything up? This makes absolutely no sense to me at all.

kk19115: My bootline looks like this:

kernel X.XX.XXXsmp ro root=LABEL=/ hdb=ide-scsi

No idea whay; I have a scsi cd drive; the os was installed on hda anyway. So, I entered this line:

kernel X.XX.XXXsmp ro root=LABEL=/ hda=ide

This got me nowhere, so I tried:

kernel X.XX.XXXsmp ro root=LABEL=/ hda

This showed the login prompt for about 2 seconds, then the monitor went down again.


kernel X.XX.XXXsmp ro root=LABEL=/ 3

Well, that seemed to work. I logged in, and was able to shudown gracefully (I shudder to think of all the damage I caused my new HD with the soft-boot button!!)

I took that one step further and entered:

kernel X.XX.XXXsmp ro root=LABEL=/ 5

This earned me another blank screen.

Well, at least I can actually crack the door.

Next, I tried to execute nano, but that got me:

-bash: nano: command not found

OK, so then I tried:


This put the screen down again

So, that's all I can think of. Anyone else care to stir the pot?

Thank you,

Joe Wilk
If nano isnt installed try pico or vi

Do you have a multi processor system? If not, why are you using an SMP kernel?

init level 3 will load linux into the console mode.

init level 5 loads XFree86 on boot up. If this doesnt work but 3 does then theres definitely a configuration problem with XFree86.
My question to you cagey, is when you reinstalled, did you select your video card drivers from the list provided by redhat or did you leave it at the default? I plan on reinstalling tonight and when I do will leave the video card driver selected as default. If this allows me to run xwindows, I will then download the updated drivers and plan to get my screen back at it's normal resolution and such. I'm a freaking newbie and don't understand most of that editing stuff yet. Let me know.
cagey cretin
kk19115, both my monitor and video card were found by the probe utility of the installation. The default parameters offered are/were within the parameters of the monitor, so I accepted. I also tried changing bit depth and resolution.

Joey, I am able to open up the file with VI.

No, not multiprocessor. Why SMP? How the heck do I know? smile.gif I had no kernel choice during installation.

Init 3 at least gets me in.

Thank you,

Joe Wilk
If nano isnt installed try pico or vi

Do you have a multi processor system? If not, why are you using an SMP kernel?

init level 3 will load linux into the console mode.

init level 5 loads XFree86 on boot up. If this doesnt work but 3 does then theres definitely a configuration problem with XFree86.
assuming u have tried..Redhat-9.0...
what installation method u have used ..
if it custom u might have selected SMP support during installation...
then check if VI is installed there..

i can't remember the exact command but i think u can configure ur x window using the command #xf86config also..
Diplsay Adapter: Radeon

What type of Radeon Adapter? (Model number 7800, 9600, 9700pro, etc. - the more specific you can be the more specific the help can be).

What do you have listed in your /etc/X11/XF86Config (you can use nano, pico, vi or emacs to edit files...) for the following variables:


Here is what it should be based on a Dell D1025TM:
HorizSync 30-85
VertRefresh 50-120

Go to the Section "Screen" part of the XF86Config file and add this:

       DefaultDepth     24
       SubSection "Display"
               Depth     24
               Modes    "1024x768@85"

Put a # in front of the lines for the above, and paste the replacement lines in....

With the exact model type, we may be able to get an ATI 3D driver to work...
kernel X.XX.XXXsmp ro root=LABEL=/ hdb=ide-scsi

That means that hdb is using SCSI emulation ... hdb is probably a CD-RW drive or a DVD player... Linux uses SCSI emulation to be able to handle DVD's and write CD's or DVD's ...

IF the smp was copied from a post I did earlier ... it was how MY machine was set up...

If you are editing your boot-up and want to change to a different runlevel then just add a space and the new runlevel ... 3 (if you want to boot to character based mode).

Run level 3 is character based mode ... run level 5 is GUI mode...
cagey cretin
Thank you all, everyone one of you, for chiming in!

I decided to try an install on a different machine (not my first choice but a good work-around). The install went without a hitch, other than still having to change the boot line (why?!!).


I have no idea why it didn't like the one machine, and I guess it don't matter a lick.

Thank you all for helping out this cretin. I plan to stay and read here, and I appreciate the hospitality.

Joe Wilk
Proud New 'Papa' of Redhat 9 Machine
you can go to the file /boot/grub/menu.lst and edit the boot line there to make whatever changes you need permanent.
Hi, I'm having the same problem myself. I tried changing
from Mandrake 9.1 to SuSE 8.2 & now my monitor went dead.
Cntrl Alt Backspace dont work but I can get in safe mode
via GRUB but config Xfree86 is a little beyond me @ the
moment but I'll try later. Until then I'm going to reload
Mandrake for the moment. I dual boot with win98 for my
wife & I'm not that great @ configuring GRUB so that
windows can be detected.
For you newbies like me that don't know anything about
Linux I recommend Mandrake to start with. Just my opinion.
BTW my pc is a HP vectra xe310 950mhz 384 ram 20GB HD
everything else standard for the time being.
cagey cretin
QUOTE (hughesjr @ Sep 11 2003, 10:58 PM)
you can go to the file /boot/grub/menu.lst and edit the boot line there to make whatever changes you need permanent.

Righteous, and thank you! wink.gif Got 'it' now...The ubiquitous 'it'.

Great advice!
Nice surprise about this shorter form. Can you tell us what it is you are talking/writing about?Has any info. about this shorter form been posted before (and i just missed it)?
If this is a legitimate post this is a long dead thread. I have no idea what you are writing about.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.