Help - Search - Members - Calendar
Full Version: More Apache Webserver Problems!
Linuxhelp > Support > Technical Support
Ravage_D
Hello All!

I cannot get my Apache Webserver to work.

I'm running Red Hat Linux 9, and the version of the Apache Webserver that I'm using is whatever came with RH9.

Now, before, the webserver would work when I typed httpd -k start.
Now whenever I type it, nothing happens. That is to say, when I try to view the index.html file in /var/www/html/, nothing comes up. (I'm trying to access the website from this computer, my Windows XP box, by typing the Linux Box's network address, 192.168.1.103).

The next thing I'd like to do is make it so apache automatically starts everytime the computer is rebooted.

If anybody out there can help me, it would be appreciated!

Cheers,

-Ravage D'Selth
Joey
Try running (as root) /etc/init.d/httpd start

To have it start at boot type setup (as root) go into "system services" and check off httpd and save it.
Ravage_D
Hey,

QUOTE
Try running (as root) /etc/init.d/httpd start


Tried it! Doesn't work sleep.gif
Joey
What happens?

Did you check your apache error_log to see what's wrong?
Ravage_D
Hey,

Apache Error log? Where is it? tongue.gif

-Ravage
Joey
Do yourself a favor and take 30 minutes to go through the apache docs. You can find them at http://httpd.apache.org/docs-project/

Your error_log should be in /var/logs/httpd/ or you can run updatedb and then locate error_log
Ravage_D
Hey,

Well, I checked the logs in /var/log/httpd and I found my problem!

I recently changed the name of my box to "Thera" so that's obviously causing problems. Here is what the log file says:

QUOTE
[Sun Sep 07 14:08:04 2003] [alert] (22002)Name or service not known: mod_unique_id: unable to find IPv4 address of "Thera"
Configuration Failed!


So, my problem is setting up my hostname, and well, finding the file where you change that (which I don't remember anymore sleep.gif)

I only want the box's name to be Thera, address, should be either thera.homelinux.com or 192.168.1.103

Thanks for the docs! smile.gif

-Ravage D'Selth
Joey
You can use /bin/hostname to set the boxes hostname
Ravage_D
Hey,

I don't know what to do to fix my hostname problem! huh.gif

I tried reading the man pages, but it's confusing....

Please help! sleep.gif
Joey
Well did you run /bin/hostname and set it up?

What happens when you change the hostname in httpd.conf to localhost
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.