Help - Search - Members - Calendar
Full Version: Web Server Not Responding To Registered Domainname
Linuxhelp > Support > Technical Support
SnowLeopard
Ok, I'm not new to the linux community but I am very new at running a web server. Currently it is correctly set up to recieve direct IP connections and will host the pages and the like with no problems. I recently purchased and registered a domain name, that came with a DNS extention. I linked the DN to the IP of the web server, but currently have gotten both the HTML 500 error, and "Cannot find server" error. I don't know if I have incorrectly set up the DN/DNS side, or if I have to reconfigur Apache (mind you I had to have help to start it, as I am very unfamiliar with apache at present of this posting) If anybody can help me atleast understand what I am doing wrong or can help provide a solution I would be in debted to them.


Jason
SnowLeopard
Weeee! More or less got it working. the website now fucntions correctly tho trying to access it with the WWW prefix fails miserably. Now to figure out and fix that problem. Any suggestions?
Joey
Did you set up the virtualhost variables in your httpd.conf file?

For example:

CODE
<VirtualHost 216.138.195.197>
ServerName www.linuxhelp.ca
ServerAlias linuxhelp.ca www.linuxhelp.net linuxhelp.net
DocumentRoot /usr/local/apache/html/linuxhelp
ScriptAlias /cgi-bin/ /usr/local/apache/html/linuxhelp/cgi-bin/
ErrorDocument 404 /404.php
</VirtualHost>
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.