Help - Search - Members - Calendar
Full Version: Tecra 8000 Sound Not Working - Mandrake 9.1
Linuxhelp > Support > Technical Support
Hi all,

Rank linux amateur here. Have been running win98se and win2k pro without complaint on my Toshiba Tecra 8000 laptop for years, but having now made the change to Mandrake 9.1, I am determined not to go back.

The sound card is Yamaha opl3-sa2. Linux does not appear to recognise its existence: it does not appear in the ¨hardware¨ section of the Mandrake Control Centre, it was not found by the installer program; is not found by isapnp at boot, it is not found by sndconfig.

There is a considerable body of work about this specific problem and I´ve tried to make what I can of it - the trouble is, while I think Ie figured out the problem, I don´t know how to find a solution.

I have:

* cut and pasted a few lines of code (setting variables below) from a web page into my modules.conf file, which then screwed up my USB and PCMCIA support. So I had to reinstall... I guess I ain ready for that step yet.

* enabled the sound server in the KDE control panel, and upon boot I get the following error message:

Informational - artsmessage
Sound server informational message:
Error while initializing sound driver:
device /dev/dsp can be opened (no such file or directory)
The sound server will continue, using the null output device.

As I understand it, sound server is required for sndconfig to work correctly?

* checked my bios settings:

wss i/o 530h; sbpro i/o 220h; irq 5; wss (play) dma 1; wss (rec) and sbpro dma 0

I am unable to set the ¨control¨ parameter: it is automatically set to wss i/o number+8; in this case 538h (or, if I change the wss i/o to 540, it becomes 548, etc.) I think this may be the rub, because sndconfig only allows me to set the ¨control¨ parameter to 370 or 380.

* run sndconfig from outside X, and tried all combinations of variables.

When it tries to play the test sound, I get the following error message:

The following error occurred while running the modprobe program:
/lib/modules/2.4.21-1.13mdk/kernel/drivers/sound/opl3sa2.0.gz init_module: No such device
/lib/modules/2.4.21-1.13mdk/kernel/drivers/sound/opl3sa2.0.gz failed
modprobe: insmod sound-slot-0 failed

... which means nothing to me.

What´s the trick to changing that control variable to 538?

If someone could help me out here, I would be much obliged.

I had to get sound working for a Toshiba Tecra 780DVD. It uses the same sound card, but the settings may be slightly different. Here is the command that I used to load the driver:

modprobe opl3sa2 snd_port 0x370 snd_sb_port 0x220 snd_wss_port 0x530 snd_midi_port 0x330 snd_fm_port 0x388 snd_irq 7 snd_dma1 1 snd_isapn

(It is all one line)....
Thanks, Hughesjr.

That half-fixes it - enables the machine to play cd audio files, etc, but mp3s still do not work. I got the same result from selecting "SBpro" in sndconfig. Unfortunately, I digitised my entire music collection, and I the cds are all in storage halfway across the world, so I do need mp3 support sad.gif

I'm also not fully certain how to use the command - if I put that line in my modules.conf, it screws up my USB and PCMCIA.

I found and tried these, in modules.conf: (from <a href="">here</a>.

# Sound Settings for 2.2.x upto (and including) 2.4.1
alias char-major-14 opl3sa2
pre-install opl3sa2 modprobe "-k" "ad1848"
post-install opl3sa2 modprobe "-k" "opl3"
options opl3sa2 io=0x220 mss_io=0x530 mpu_io=0x330 irq=5 dma=1 dma2=0
options opl3 io=0x388


# Sound settings for 2.4.2 and beyond (tested with 2.4.3)
alias char-major-14 ad1848
pre-install ad1848 modprobe "-k" "mpu401"
post-install ad1848 modprobe "-k" "opl3"
options ad1848 io=0x530 irq=5 dma=1 dma2=0
options opl3 io=0x388

Have tried each "as is" and tweaking the settings to match my bios. Always the same result: no more error message from the Sound Server on KDE startup, no more error message when playing a cd track or mp3 in XMMS, but no sound either. Also not sure what the importance of these lines are:

insmod soundcore
insmod sound
insmod mpu401
insmod ad1848 io=0x530 irq=5 dma=1 dma2=0
insmod opl3 io=0x388

I made the mistake of putting them into my modules.conf as well.

Where/under what circumstances should insmod and modprobe commands be used? Should these be included in another config file, or run at some other stage?

I also note that there are different settings required for different kernels, and that the kernels mentioned are much older than the one I've got with mdk 9.1. Would it be worthwhile going back to an older version of linux with an older kernel? Is it possible/feasible to recompile the kernel in order to overcome these issues?

Thanks for your patience smile.gif
Make sure to check the sound controller .... some things may be muted. Are you using KDE or Gnome?

The Kmix volume controller settings are strange ... the slider all the way up is 0 .... and moving the slider down increases volume ... this is unnatural to me, and I use real soundmixers all the time. Since I don't use KDE, I might have never figured it out, except I opened aumix.

In the program aumix the sliders move from side to side ... and 0 is if using KDE try aumix (aumix also works in Gnome).

The Gnome sound controller (gnome-volume-control) has 0 sound at the bottom and you move the sliders up to increase volume (the more natural way, in my opinion).
Older version / kernel is not better .... the newer versions have better sound support. The problem is that the sound support for this card is ISA and not PCI....
A good thing to use (to see what you can pass to a module) is modinfo ... so use the commands:

modinfo ad1848

modinfo opl3

modinfo opl3sa2

modinfo mpu01

to see the possible inputs to each module....

I no longer have Linux on that laptop ... I had to install Windows XP so I could use it to record live wma files for a website , BUT,

What happens if you try this in your modules.conf

alias char-major-14 ad1848
pre-install ad1848 modprobe "-k" "mpu401"
post-install ad1848 modprobe "-k" "opl3"
options ad1848 io=0x530 irq=5 dma=1 dma2=0 soundpro=0x220
options mpu401 io=0x330
options opl3 io=0x388

How about this in modules.conf

alias char-major-14 opl3sa2
pre-install opl3sa2 modprobe "-k" "mpu401"
post-install opl3sa2 modprobe "-k" "opl3"
options opl3sa2 io=0x370 mss_io=0x530 irq=5 dma=1 dma2=0
options mpu401 io=0x330
options opl3 io=0x388

You would use modprobe or insmod commands seperately in an executable script (not in modules.conf) .... that you could run on startup.
I'm using KDE 3.1, as installed. I'm finding it a bit bloated though, would like to try gnome but it doesn't seem to have been installed (though two other window managers and most everything else under the sun has).

Neither "alias" block in modules.conf works. They suppress the error message I'd normally get when trying to play an mp3 or sound file, but they don't actually yield any sound. The modprobe line you gave me worked for cd audio (perfect playback, no problems), but not mp3s (xmms says it's playing, even shows spec analyser, but no sound is forthcoming).

Under these circumstances, none of the mixer programs will even run (aumix simply won't load; kmix gives me a choose mixer dialogue with no options). This is true even after running the modprobe line; however, if I use the SBpro block in my modules.conf, the mixers run fine. Sound performance, however, is identical: cd=ok, mp3=silent.

Modinfo looks like it will be some use. The opl3sa2 moddule actually utilises the ad1848 driver, which explains why some people have used settings for that card in the past.

There are a bunch of options I can try, including turning off multiple card support and isapnp detection. Also will try a few switches with the SBpro driver - plenty of cards work fine emulating a sbpro in windows, could it be the same in linux?

Thanks again for your help.
Alright, an update:

Have tried various switches including isapnp=0 and multiple=0 using modprobe on the ad1848 and opl3sa2 modules, and isapnp=0, reverse=1 and pnplegacy=1 with the sb module; no difference from before.

Also located another set of modules.conf commands (found <a href="">here</a>) which actually match my BIOS settings:

alias sound opl3sa2
pre-install sound /sbin/insmod sound dmabuf=3D1
alias midi opl3
options opl3 io=3D0x388
options opl3sa2 mss_io=0x530 irq=5 dma=1 dma2=0 mpu_io=0x330 io=0x538

But these provide no joy, either.

Have also found some info (<a href="">here</a>) about recompiling the kernel to fix it - though it looks to me as if that's just "hard-wiring" the modules.conf settings into the kernel. Is this correct? Is it necessary? I've not had to recompile anything so far, and I've got some serious RTFMing to do....

Any further ideas? Any diagnoses about why this may not be working?

Thanks again,
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.