Help - Search - Members - Calendar
Full Version: Red Hat Dns Configuration Problem
Linuxhelp > Support > Technical Support
Hi there,

I've recently installed Red Hat Linux 8 onto my PC, which is running as a client on a household network governed by Microsoft servers.

I obtain my IP address from a DHCP server, whose address I have entered in the network settings screen in GNOME. I have also entered the IP addresses of a Primary and Secondary DNS server in the DNS tab. I am mystified as to what I should enter as the HOST though, so this field is currently blank.

The main problem I'm having is that it's taking ages for Linux to resolved URL's on a broadband connection. This should not be happening. However, when I enter the IP address for the URL, my browser hits it immediately. This all points to my DNS not being configured correctly; especially as I've now disabled the firewall.

Can anybody offer any suggestions, or pointers to any online documentation that could prove useful?
Are you using the internal DNS server? Normally on Home networks, the Firewall/Router (or ICS compter) is also a DNS server....and that should be part of DHCP....

You should not manually enter any IP addresses if you are using DHCP ... nor should you enter a DNS server or Default gateway. All of that should be obtained via your DHCP.

If you want to set the information manually, you can ... but pick something outside the dhcp range (unless you can make DHCP reservations).

Your host name can be anything ... it is like windows computer name.
Have just erased all reference to the DNS servers (Turned out they belonged to Pipex; my ISP), and set my network settings to just use DHCP, and obtain DNS from the ISP.

However, I cannot now translate URL's, and my browser is coming up with "address not found" error messages.

Have done a little diagnoses (pinging), and have discovered that DHCP is definitely working, as my Linux client has been allocated an IP address by the DHCP server (the same IP address as when I run Windows XP, so I know this is definitely correct - nothing I've added myself).

I can ping the IP address of any website, but not its URL (bar those I've already had resolved by DNS, very slowly, on previous occasions). My conclusion for the moment is that I need to make reference to those DNS servers in my network settings.

Any other suggestions?
What is your DHCP server? Is it a local IP (like or are you getting IP's on the Linux box from your ISP?

Are your windows machines also DHCP ... if so, type this command in a command prompt on a windows machine:

ipconfig /all

And use the DNS server from the windows machine ....
The DHCP server is a local IP (beginning 192.168......etc).

The Windows machine is also DHCP, and I'm already attempting to use the same server for my Linux web connection (IP address obtained in MS DOS using the ipconfig /all command). The DNS servers displayed by this command are those belonging to Pipex, and these are the servers I'm currently attempting to use.

Thanks for the help so far though. Got any other suggestions?
I'm not sure why the connection is so slow ... weird...

You might try adding and configuring bind to your linux box, setting it up as a caching-only DNS server ... then it can do it's own lookups.

Here is bind configuration info for caching only server:
Hi there,

Got a theory about the network conncetion from my housemate (a Microsoft Network support engineer). I've now got an identical problem in Windows XP. Basically (and this is in windows now) my LAN connection should be running at 10Mbs - half duplex. However, when I run it at this speed, I lose my connection to the DHCP server. To regain my connection, I have to run at 100Mbs - full duplex. This is too fast for the web, which then dowloads pages really slowly.

My housemate seems to think that Linux has done 'something' to the network card, and has asked me to check the network connection speed in Red Hat. Do you know where I can find this setting?
Turns out my housemate's Linux 'theory' was a loada rubbish. However, I have a new theory. I am connected to our LAN via a poor network cable that cannot handle fast connections. I need to connect via 10Mbs - full duplex ideally. I suspect my Linux connection is running at a faster speed by default - maybe 100Mbs at a guess. It was interesting to note that when I was running at this speed in Windows XP, my web connection ran as slowly as it does in Linux.

Does anyone know where I can set the network connection speed in Linux?
BTW ... the problem with your line is that it doesn't support 100mb (it is probably a category 3 line vice a category 5 line) ... so you have lots of collisions ... and you have high packet loss rates ... so retransmissions are required for everything ... so it is very slow.
How to adjust....

It depends on your specific network card, and wether you load it as a module or built-in to the kernel.

On a standard Linux install, the network card is loaded as a module.

Do you know what module your network card is using?

you can use the command:

dmesg | grep eth0

My output looks like this:
divert: allocating divert_blk for eth0
e100: eth0: Intel® PRO/100 Network Connection
e100: eth0 NIC Link is Up 100 Mbps Half duplex

... so my eth0 module is e100

You can also look in your /etc/modules.conf file for the eth0 alias line ... mine says:

alias eth0 e100

.... another common module is tulip. Each module would be setup differently to turn off auto sense.

You can see the options allowed by typing the comand:

modinfo module_name

so for module e100, the command would be:

modinfo e100

And the output is:

filename: /lib/modules/2.4.20-20.9smp/kernel/drivers/net/e100/e100.o
description: "Intel® PRO/100 Network Driver"
author: "Intel Corporation, <>"
license: "GPL"
parm: TxDescriptors int array (min = 1, max = 16), description "Number of transmit descriptors"
parm: RxDescriptors int array (min = 1, max = 16), description "Number of receive descriptors"
parm: XsumRX int array (min = 1, max = 16), description "Disable or enable Receive Checksum offload"
parm: e100_speed_duplex int array (min = 1, max = 16), description "Speed and Duplex settings"
parm: ucode int array (min = 1, max = 16), description "Disable or enable microcode loading"
parm: ber int array (min = 1, max = 16), description "Value for the BER correction algorithm"
parm: flow_control int array (min = 1, max = 16), description "Disable or enable Ethernet PAUSE frames processing"
parm: IntDelay int array (min = 1, max = 16), description "Value for CPU saver's interrupt delay"
parm: BundleSmallFr int array (min = 1, max = 16), description "Disable or enable interrupt bundling of small frames"
parm: BundleMax int array (min = 1, max = 16), description "Maximum number for CPU saver's packet bundling"parm: IFS int array (min = 1, max = 16), description "Disable or enable the adaptive IFS algorithm"

So the parmeter I would need to adjust is e100_speed_duplex.

Here is some info for the e100 module:

Here is a table for the tulip module:

When you find your module, you would use a line like this in your /etc/modules.conf right below the eth0 line (I'll do the 10bt Full Duplex for e100 from the above link)

options e100 e100_speed_duplex=2

If you have tulip, the line would look like this:

options tulip options=4
Hi there,

Tried the command dmesg | grep eth0. I received the following output:

divert: allocating divert_blk for eth0

Unfortunately, no module name was forthcoming.

I checked the contents of /etc/modules.conf for the eth0 alias, and found the following line:

alias eth0 3c59x

This looks like my alias is a hex-like value - not sure how to interpret this.

Tried the modinfo e100 command and received the same output as yourself. Obviously, this module has been installed, but I'm not sure if that means I'm using it by default. Over to you for that answer......

Added the line options e100 e100_speed_duplex = 2 to the /etc/modules.conf file, and then rebooted. Web connection still running very slow (as would be expected if, indeed, I'm not running the e100 module), so this does not seem to have worked.

Thanks for the help so far though. What is your interpretation of these results?
3c59x is a 3com card .... it is also fairly standard ...

here is the magic line you need to add to your /etc/modules.conf (just below the eth0 line)...

options 3c59x options=0 full_duplex=1

here is a link with info:

If that doesn't work, try this:

options 3c59x options=10 full_duplex=1
Tried both options 3c59x options=0 full_duplex=1
and options 3c59x options=10 full_duplex=1

On both occasions, I lost my conncection to the network (network not reachable error message in the command window).

I'll have a play around with the different settings later, and see if I can find a combination that restores my connection.

In the meantime, do you have any other ideas?
The 2 lines in the modules.conf should look like this:

alias eth0 3c59x
options 3c59x options=0 full_duplex=1


alias eth0 3c59x
options 3c59x options=10 full_duplex=1

do dmesg and also look in /var/log/messages and see if the options loaded properly.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.