Help - Search - Members - Calendar
Full Version: Need To Revert To Glibc 2.2
Linuxhelp > Support > Technical Support
We installed GLIBC 2.3 on our RH AS 2.1 system in error. We are now receiving an error line on our printer (whenever we print a file), that says - "Incorrectly built binary which accesses errno, h_errno or _res directly. Needs to be fixed." This is the only symptom we are receiving, but Red Hat says they only support GLIBC 2.2. We tried to force the reinstall of 2.2 using RPM, but since we have a version number greater already installed, it refused. Is there a way to get back to GLIBC 2.2 without completely reinstalling Linux? Can we find out what program is creating the error and fix it? We have all our applications and data loaded on this box ready to go live - a reinstall would be very unhealthy (for our jobs). We need some ideas. Thanks!
Are you sure that glibc is the only thing upgraded?

You can use the command:

rpm -e --nodeps glibc

to remove the glibc 2.3

then use:

rpm -Uvh glibc-xxxxx-.rpm ... but if other things are also installed at values higher than required by glibc 2.2 then you may get errors and no install....
We were told by Red Hat that removing GLBIC would create an unstable system that may not be bootable. We cannot afford to destroy this box since we are so close to going live. We did not install any other upgrades. Red Hat says that GLIBC ver. 2.3 is not supported in their Advanced Server 2.1 - so we assume this version is causing the problem.
not having a glibc WILL make a box not bootable, that is for sure .... but you will be re-installing the correct glibc.

You can FIRST run the command:

rpm -q --filesbypkg glibc

Which will tell you every file installed by that package ... so you can back them up and replace them later if you want.

You can try the command:

rpm -Uvh --replacepkgs --replacefiles --oldpackage --test glibc-xxxx.rpm

The above command won't actually do the upgrade ... it will just report about what it would do.... then remove the --test if it says it will run.

This should upgrade the package and replace all the glibc 2.3 files with the glibc 2.2 files...

What each of the switches mean are as follows:
Install the packages even if they replace files from other,
already installed, packages.

Install the packages even if some of them are already installed
on this system.

Allow an upgrade to replace a newer package with an older one.
Apparantly another package was updated that is dependent on GLIBC 2.3. This is the message I get when I try to force an update to GLIBC 2.2 -
Failed dependencies: is needed by binutils-

Can I remove binutils also and install the older version? If so, in what order? glibc then binutils, or binutils first? Or am I really screwed?
In looking at the RedHat website for 2.1 Advanced Server (i386), I get these as the most current versions:


I would recommend that you check all your actually installed files agianst this list:

2.1AS I386 Original install:

updates since release:
If the only things that are wrong are the glibc and binutils, then you can do this to fix it:

obtain glibc-2.2.4-32.8.rpm and binutils- and put those files in a temporary directory and go to that directory... test the install using this command:

rpm -Uvh --replacepkgs --replacefiles --oldpackage --test glibc-2.2.4-32.8.rpm binutils-

(the above command is all on one line ...) ... if no errors, remove the --test and try....
The suggestions worked! However, I had to add the --nodeps switch to the rpm command to allow the binutils to reinstall. A query of the installed packages now reports the correct versions. Thanks for your help!!
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.