Help - Search - Members - Calendar
Full Version: Installing Linux V8.0
Linuxhelp > Support > Technical Support
mapss
I have installed linux V8.0 on my machine but on booting it hangs after the message "Enabling Swap Space". Searching for any other people who have experienced this error it is something to do with an AGP graphics card- and you need to alter the rc.syncinit file to fix the problem but I do not know how to do this. I am new to linux and need step by step instructions!
Is this problem fixed in V9?
Many thanks
hughesjr
try booting up on the RedHat 8.0 boot disk and at the first prompt, type:

linux rescue

Skip the media check:

You should then get the option to mount your install in /mnt/sysimage. Do that, and if all goes well, change directories to:

cd /mnt/sysimage/var/log[b]

You can then look at the files [b]boot
, mesg, and dmesg (also the same files with a .1) to see what happened when the system hung ... it will be the last couple entries in the logs.

You can use the command:

less boot

(to move around in less, use the arrow keys .... the keys Shift-G will go to the last line of the file ... the number 1 followed by Shift-G will go to the top of the file .... q will exit less)

Repeat for the other files ... post any errors you find near the end of your files here and we might be able to help....
mapss
Hi

I typed "linux rescue" at the first prompt. Unfortunately the process got to the same place and hung at "Enabling Swap Space"
I have been told that commenting out lines 583 to 585 of rc.syncinit should fix the problem. I have tried typing linux single init=/bin/bash at the first user prompt to stop the boot before the problem but I cannot change any files because my file system is read only at that point. How do I change this?

Many Thanks
hughesjr
I have a redhat 8.0 install on 2 machines ... and I don't a file named rc.syncinit..

I do have a file named /etc/rc/rc.sysinit .... but remarking out lines 583 to 585 would totally break the script ... it is the middle of a do case statement.

If you boot from your installation CD 1, using linux rescue, you have a enabling swap space error?

If so, this looks like your error:

http://bugzilla.redhat.com/bugzilla/show_b...ug.cgi?id=81324

It is fixed in version 9.0 of redhat ... you can also probably use a mandrake boot disk to find and remark the offending code....but you wouldn't be able to use DMA on any of your hard drives ... not good. My next post has a better fix...but the best would be to use redhat 9.
hughesjr
If that is your problem, I have looked at the script rc.sysinit. Here is a way to fix your problem.

Turn off the PC, open the unit and remove the power plug to the CDROM ... it seems the hang is caused by the DMA adjustment to the CDROM...

Now the hard drive should boot.

... once you are able to login, do the command:

ls -al /dev/cdrom*

The result should look like this:

lrwxrwxrwx 1 root root 8 Nov 6 2001 /dev/cdrom -> /dev/hdc

The important part of this is the /dev/hdc.

Go to the directory /etc/sysconfig and copy the file harddisks to harddiskhdc ... the hdc coming from the /dev/hdc ... which is the cdrom. This would be the command:

cd /etc/sysconfig
cp harddisks harddiskhdc


Then edit the file harddiskhdc and set USE_DMA=0

shutdown the PC and connect the power to the CDROM and reboot ... see if it works!

----------------
If your PC supports using RedHat 9, the drivers are better for that chipset and it doesn't crash, so I would use RH9 if possible ... because you can't use DMA with the CDROM, so playing VCD's and DVD's would be jittery and probably drop frames.
mapss
Thanks for the advice.

I will buy Redhat 9.0 and hopefully it will work.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.