Help - Search - Members - Calendar
Full Version: Help W/ Saving To Windows Drive
Linuxhelp > Support > Technical Support
jason122
Hi, I'm new here and somewhat new to Linux. I am currently running RH9, and need some help with access to a drive. I have a partition (hde2) formatted as FAT32, and store all of my stuff from Windows here. I would like to be able to save things in RH to this drive, but currently can't. I have mounted the drive and can read from it, but can't save anything to that drive. Can't create any files, folders, nothing. I've looked around for what might be the cause and found a few things that didn't quite get it. I added a line to my fstab file that reads:
/dev/hde2 /mnt/mydocs auto auto,rw,user,exec,unmask=000 0 0
The hard drive is now mounted when the system starts up (nice) but I still can't save anything to the drive. I have also added myself to the adm and root groups and still can't save to that drive. I've tried changing the permissions on /mnt/mydocs (the mount point for the drive) and get an error back that says I can't perform that operation or something like that. I'm a little stumped. I appreciate any help that you could offer, and if you need any additional information or have any questions for me, please let me know.

Thanks in advance!
Jason
Joey
What is the exact error message you get when trying to save to the partition.

Can you try it as root and see what happens.
jason122
I can save to the drive when su root. If I try it as user Jason I receive the following message:

mkdir: cannot create directory `test2': Permission denied

Here is what I get if I try to change the permissions on the /mnt/mydocs directory:

[root@localhost mnt]# ls -l
total 32
drwxr-xr-x 2 root root 4096 Jul 6 16:29 cdrom
drwxr-xr-x 2 root root 4096 Jul 6 16:29 cdrom1
drwxr-xr-x 2 root root 4096 Jul 6 16:29 floppy
drwxr-xr-x 5 root root 16384 Aug 10 13:25 mydocs
drwxr-xr-x 2 root root 4096 Jul 6 16:29 zip
[root@localhost mnt]# chmod a+w /mnt/mydocs
chmod: changing permissions of `/mnt/mydocs' (requested: 0777, actual: 0755): Operation not permitted
[root@localhost mnt]#
jason122
Ok, I tried this and it seems to be working now. I modified my fstab file to look like this:

/dev/hde2 /mnt/mydocs vfat uid=500,gid=500,unmask=002,auto,rw,user,exec, 0 0

If I understand it correctly....uid is the user owner, gid is the group owner, not sure what unmask does....do you know?
hughesjr
The problem is that directory permissions are

rwxr-xr-x root root

Meaning that root user has read, write, execute permissions, but the root group and everyone else has only read and execute (no write).

Before you issue the chmod command, you must unmount the drive....

cd /mnt
unmount /mnt/mydocs


Then change permissions:

chmod -R 777 /mnt/mydocs

Then mount it again with:

mount /mnt/mydocs

That should do it....
jetblackz
Do yourself a favour next time you're not sure what something does.

man mount

umask is interpreted the opposite. 002 = 775 = full read/write/run for owner and group, run only for others. Personlly, I prefer 007 = 700.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.