Help - Search - Members - Calendar
Full Version: Rh9 Prntr Lets Xp Print Only If Security=shared
Linuxhelp > Support > Technical Support
I am running Red Hat Linux 9 and sharing an Epson 880 printer. All disk shares work perfectly, but I couldn't print to the Samba shared printer from my Windows XP Home computer until I changed 'security = shared'. When I had security set at 'user', I would see the printer and could install it in XP, but whenever I attempted to print I received the error, "Access Denied, Unable to Connect". I made sure to log into WinXP as the same user and password as one of my users on the Linux machine and I set the guest account on Linux to this very same username. I also had write permission on the spool directory and /dev/null. The printer was set to allow all hosts in Linux and testprns showed no errors.
Anyone have a clue why changing from 'security = user' to 'security = shared' suddenly allows printing? If so, do you have any solution so I can put security back to user and make changes elsewhere to get such a setup to work?

Print shares don't work the same as file shares ... and print shares require a guestaccount to print. If you use security = share a guestaccount is automatically used for print shares, if you use security = user then you have to manually setup the guestaccount info.
Here it says:

You should also use security = share if you want to mainly setup shares without a password (guest shares). This is commonly used for a shared printer server. It is more difficult to setup guest shares with security = user, see the map to guest  parameter for details.

So if you want to use security = user then for printing shares you have to setup (or pick) a guest account. This user should be able to print ... but not be a member of the Linux users group. The user nobody is a good choice for guest account = if it exists (try it and see if it works ...), if nobody doesn't work ... create a print user, make sure it can print, and take him out of all groups...

then in the [printers] section add:

public = yes
guest ok = yes

and in the [global] section change:

map to guest = Bad User
guest account = guestname
or just use security = share
Here is some more info on Printing in Samba:
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.