Help - Search - Members - Calendar
Full Version: No Network Card!
Linuxhelp > Support > Technical Support
mike
I have a computer with an integrated network card. Its in the motherboard. (http://www.msi.com.tw/program/products/mai...tail.php?UID=10)
Everything works great in Redhat 9, but it doesn't find my network card. Anyone an idea what I could do?
ctrunk514
I have such a hard time with Linux hardware, its like if Linux does not automaticaly detect and have the drive for the device im out of luck.

Mike,

Have you tried going to MSI's website and trying to locate a Linux driver for whatever NIC it is? Most of the time, if a driver exists, it will include some kind if instructions on how to install it.
mike
They have no network drivers and the drivers they have on the msi site are win* only sad.gif.

I think I have to manually configure my network card but I don't have a clue how to do this :-/.
hughesjr
QUOTE
I think I found the problem! laugh.giflaugh.gif  (just a little bit of humor!)


I think the drivers from this page will work....

http://www.nvidia.com/object/linux_nforce_...e_1.0-0261.html

If you are using either the 2.4.20_6 kernel or the 2.4.20_9 kernel, you can install an rpm ... otherwise you will have to use the NVIDIA_nforce-1.0-0261.tar.gz file.

To check the kernel you booted into now, use the command:
uname -r

To see which kernels you have installed, use the command:
rpm -qa | grep kernel
mike
I downloaded the driver but after installing it I still didn't had a working networkcard.

But I read in the README of the driver something about a PnP setting in the motherboard bios. So I switched that setting and then it reconized my network card! Now it works smile.gif.

I never thought about that setting because in windowsXP everything worked smooth smile.gif.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.