Help - Search - Members - Calendar
Full Version: Networking Problems
Linuxhelp > Support > Technical Support
Chucky
Well I had planned to show you a lot more information, but it turns out since installing Redhat 9 my modem (sm56) doesn't work either - but I'll leave that to another thread biggrin.gif

Anyway I've just installed Redhat 9 along side Windows XP and now Redhat is unable to communicate with my Windows XP laptop - although when I reboot back into Windows XP I have no problems.

I have my network card setup, ifconfig and the Redhat config thingo shows it is there, with the IP address 192.168.0.1 and subnet 255.255.255.0, the laptop is the same but 192.168.0.2.

Neither can ping the other - Redhat can ping itself, but the laptop can't even manage that (but remember the latop is not at fault as it works fine when I reboot the main computer into XP).

Running tcpdump I find something similar to this (I apologize if the modem worked it would be cut and paste!):
"arp whohas 192.168.0.2 tell 192.168.0.1"

So it's trying to find out the MAC address - so I try and be smart and manually edit the arp table so that it already has the MAC address. Well now the pings get sent - but they get no response.

Occasionally the tcpdump gets packets from the XP laptop with something along the line of "BROADCAST netbios... blah blah ...192.168.0.2" so some traffic is making the trip.

To be sure it's not a firewall problem I have disabled the firewall and completely cleared the iptables of all of the REJECT lines.



I am a newbie, last Friday was the first time I ever touched Linux so please help me smile.gif I'm a quick learner and hopefully will be able to help others on the forum once I've figured it all out.
hughesjr
You didn't really say how many network cards in the first machine ... or if it is your DHCP server and ICS gateway for the rest of the network, etc....

1. I'm not sure how your network is setup, but 192.168.0.1 is a very common address that a cable modem, DSL modem, or ICS would use as a default gateway to the internet. Are you sure that 192.168.0.1 is not taken by another device on your network? Or maybe this is your ICS Gateway (and therefore also your DHCP and DNS server).

2. This is just a stab.....(if your WinXP PC is the ICS gateway to the Internet) .... The problem may be that the WinXP machine (non laptop) might be your DHCP server ... therefore your laptop may not be 192.168.0.2 if you boot it and there is no DHCP server (the other XP computer) running at 192.168.0.1 on the network.

So, are you assigning the IP manually to the WinXP laptop .... can it ping itself when you boot both in XP?

The command to check your actual IP in WinXP is ipconfig. When the laptop can't ping itself, what is it's IP ... using the command (from a command prompt):

ipconfig /all

If the IP is 169.254.x.x with a subnet mask of 255.255.0.0 then you have no DHCP server and XP assigned a bad address.

You may just need to make a manual assignment of the IP on the Laptop before you boot into RedHat.

--------------------------------------------
If RedHat properly made the IP assignment, you will have a file named /etc/sysconfig/network-scripts/ifcfg-eth0 and it will say this:

DEVICE=eth0
BOOTPROTO=static
BROADCAST=192.168.0.255
IPADDR=192.168.0.1
NETMASK=255.255.255.0
NETWORK=192.168.0.0
ONBOOT=yes
-------------------------------------------
If both the laptop IP and the RedHat IP check out, then you should be able to ping....let us know!
Chucky
Well I'm at school so I can't try out what you've said, but I'll point out of few things that I forgot in the first post.

1. One network card in the Linux computer (dual harddrive - Redhat 9, XP), one network card in the XP laptop.

2. There is no internet sharing enabled, both computers have dialup connections but they are not shared (nor does the Linux one even work huh.gif).

3. The laptop has been set to 192.168.0.2, IPCONFIG shows this - havent tried ipconfig /all just yet but will do when I get home. The laptop cannot ping itself, but it can when the Linux machine is rebooted into XP.


As I am at school I cannot check the /etc/sysconfig/network-scripts/ifcfg-eth0 file, however running the ifconfig comman on Linux reveals the following:
broadcast: 192.168.0.255
ip address: 192.168.0.1
netmask: 255.255.255.0

As for the network, I can't from memory remember that being there.

Thanks for your help, I will when I get home check what you have told me and then post again here.
Chucky
ok well checked everything, the /etc/sysconfig/network-scripts/ifcfg-eth0 file looks exactly like you said it would. The laptop is manually set to 192.168.0.2 and is unable to ping itself.

One idea I had would be to try setting the Linux box as a dhcp and see if Windows could get an ip - but I don't even know where to start to get that happening wink.gif

I've already tried enabling internet sharing on the xp laptop to see if Linux could get an ip - no luck sad.gif

Any ideas are welcome biggrin.gif
Chucky
Well it's working, I got dhcpd working on the Linux box and the laptop can now get an ip - now to work out samba wink.gif


...and to get that damn sm56 working!
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.