Help - Search - Members - Calendar
Full Version: New Pci Nvidia Card Not Found?
Linuxhelp > Support > Technical Support
Medic6666
I have got a new G-Force FX 5200 PCI card. The reason is I dont have a AGP slot on this pc.

I have a mobo that has onboard GFX but there is no where to disable it.

When I go to the display panel and click probe videocard it only find the onboard.

What can I do to get the PCI card to be reconised.

I am actually using it but there is a memory problem because its using the onboard settings and keeps crashing my pc.

Thanks

Medic6666
Joey
There has to be a way to disable the onboard video, double check the bios.

What motherboard do you have?
Medic6666
The mobo and bios is old and there is no way to disable the onboard. I have checked the website and have confirmed this.

I am right in thinking that the new nvidia drivers should support all nvidia cards on the market at the moment?

and also that

by using the drivers this means that linux its self does not need to support the card?


I know this is a bit drastic but is there a way to cripple the onboard so that it dont work or would this kill the whole mobo?

Cheers

Medic6666
hughesjr
Use this command to find out where your new video card is on the PCI bus:

lspci -grep VGA

It should produce a list like this:
01:00.0 VGA compatible controller: nVidia Corporation NV5 [RIVA TNT2/TNT2 Pro] (rev 15)

My agp video card is at 01:00.0 ... yours will be somewhere else smile.gif. We will refer to it like this:

XX:YY.Z (so in my case, XX=01, YY=00 and Z=0)

If you don't have the command lspci , it is in the package pciutils.

Once you know the location, goto your /etc/X11/XF86Config (or XF86Config-4) file and add the following line in the device section for your new video card:

BusID "PCI:XX:YY:Z"

so on my PC, it would be:

BusID "PCI:01:00:0"

Notice there are only : and no . in the BusID line ... but there is a . in the lspci output!

-----------------------

Then go to the Screen section of your /etc/X11/XF86Config (or XF86Config-4) file and make sure that the device line has the Identifier of your new card in it...not the original card...

This will use the new Card for Xwindows ....
----------------------
If you haven't yet installed the nvidia drivers, use the line:

Driver "nv"

in the device setion for your new card .... or if you have already installed the nvidia drivers then use the line:

Driver "nvidia"

in the device section for the new card....
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.