Help - Search - Members - Calendar
Full Version: Libpthread.so.0: No Such File Or Directory?
Linuxhelp > Support > Technical Support
bigB8210
I have run into a slight problem, I have installed java SDK's on a Linux Kernel machine, but whenever I go to do a command I keep on getting the same error message (Note: the /usr/j2sdk1.4.2/bin/javac changes depending on the command I enter but the rest is the same)

CODE
/usr/j2sdk1.4.2/bin/javac: error while loading shared libraries: libthread.so.0: cannot open shared file: No such file or directory


I have re-installed the java SDK's several times but still end up with the same problem, I got the SDK's from the java.sun webpage, and also tried different versions of the java SDK's and always get the same answer.

Any help you can offer would be greatly appreciated.

Thanks
Joey
Sorry I have no ideas on this one. I tried searching http://www.google.com and couldnt find anything decent on the subject.

You might want to post your problem in the Java forums on Sun's site - http://forum.java.sun.com/
bigB8210
Thanks for the suggestion but I already tried there and after two days of no replies I was refferred to this forum

Thanks
chrisw
is it libthread.so.0 or libpthread.so.0
that cant be found...cause in the title
or your post you mention libpthread
and in the other part you mention
libthread.so.0
Joey
What distribution are you running? Apparently libpthread is included in the glibc rpm package if you're running redhat.
hughesjr
I had a seperate, but similar problem caused by the JDK being compiled with an older version of C. If you are using glibc 2.3.x then I would recommend that you use the JDK from here:

ftp://ftp.tux.org/pub/java/JDK-1.4.1/i386/01/

You can download the one that was comiled with gcc3.2 or the one compiled with gcc2.95.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.