Help - Search - Members - Calendar
Full Version: Newb Problem Installing Slackware 8.1
Linuxhelp > Support > Technical Support
Iznogood
Hello, i wanted to start with saying that Im pretty much a ms fool (since 1990), but a week ago i got tired of defragmentating/scandisk'ing/reinstalling/formatting/smashingmykeyboardintopieces just to get some work done on windows. Thats when I decided to get linux.

I have tried a lot this week to get slackware installed but it keeps giving me errors, now ive had my bit of "trial and error" wich brought me to the point where the setup said :

" Your source device cannot be accessed properly.
Please be sure that it is mounted on /var/log/mount/slakware
and that the slackware disks are found in the sub-directories of /var/log/mount/slakware. "

After I press enter it also says 5 times :

*some dirs*/setup : cannot create mnt/etc/fstab: directory nonexistent

I know it has to do something with the last but I really cant figure it out, so maybe u guys could help me?
I will try to explain everything i know :


Ive made an ext2 and a swap partition, my ext2 partition is primary and between fat32 C: and D: and the swap is after D:

Ive downloaded the files - loadlin.exe, color.gz and bzimage from bare.i ( or no_kdb.i, i dont remember tho )
then i go to dos and type

c:>loadlin bzimage rw root=/dev/ram initrd=color.gz load_ramdisk=1

everything goes well, then most of the time I try to mount my cdrom and my linux partition incase it goes wrong

I try to mount my linux partition by typing
# mount -t ext2 /dev/hda3 /mnt
this seems to work allright but I actually dont have a clue if it worked

but when I try to mount my cdrom in a lot of different ways, it keeps saying "mount point ... does not exist"
I tried stuff like
# mount -t iso9660 -o ro /dev/cdrom /mnt/cdrom
# mount -t iso9660 -o ro /dev/cdrom /cdrom
# mount /mnt/cdrom
and all kind of stuff I found in the book on slackware.org

Now Im pretty sure mounting my cdrom and linux partition isn't the answer since the setup does this already, My wildest guess that its a newb problem having to do with me forgetting something, i just cant figure it out why the fstab does not exist or doesnt work, or should i make the fstab myself?

I dont know what more I have to add but im 100% sure my pII can run linux

I really hope u guys could help me smile.gif
(btw my explorer has crashed 4 times while i was writing this in notepad...) ph34r.gif

p.s. rtfm will do if its to stupid... unsure.gif
Iznogood
please? sad.gif
Rooster
If you want to start learning Linux without the hassle, and have some user friendliness, get RedHat.

If you really think you're tough enough, get Debian, it's great to learn on.

If you dont really want to learn Linux through and through but would like an excellent work environment, get SuSe (latest version is 8.2) and it's very very nice.
frodo44
I'm not sure whenabouts the /dev/cdrom pointer is created, but my guess is that it's not created yet. In order to get an idea of what the device is called, you need to what ide cable the drive is on and whether it is master or slave. IDE 1 - master is hda, IDE 1 - slave is hdb, IDE 2 - master is hdc, and IDE 2 - slave is hdd. You might try that. After you find that out try this:

mount -t iso9660 /dev/hdc /var/log/mount/slakware

assuming that your cdrom is hdc ( it pretty commonly is if you don't have a second hard drive).

Hope this helps a little.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.