Help - Search - Members - Calendar
Full Version: No Lan After New 2.4.21 Kernel Compile
Linuxhelp > Support > Technical Support
grasshopper
I am running debian gnu linux 3.0
I recently compiled a new kernel for my system (2.4.21), all seemed good until i noticed that i did not have lan functionality. I have on board lan (Realtek 8100B, support 10Mb/s and 100Mb/s operation).
It seems to me like the kernel didn't detect my lan or something? This seems puzzling since I just checked and I definitely compiled the kernel with lan support and tcp and all the obvious lan stuff...
If I run ifconfig with eth0 and an ip address, it gives me an error... something to the effect of eth0 can't find device (i can get the exact error msg if you need). Anybody have any ideas of what to try next to get my lan connection up and running again? Note: before I was running a 2.2.something kernel and lan worked just fine. Bizarre.
warheros
you could always take the LAN stuff out of your previous kernel and replace what you have as the LAN stuff in your new kernel with it...? i dont know though besides that, just an idea.
Corey
First off, check to make sure you have the kernel module loaded with "lsmod". Chances are, it's not there. If you compiled the card into the kernel, then check the output of your dmesg to see if the network card was detected whatsoever. Otherwise, go back into your "make menuconfig" and go back to the networking device section, go to your kernel module (i'm not sure what it is for your device, i have a realtek, and mine is 8139too) and compile it as a module. Exit and save and run "make modules && make modules install". Then "modprobe -v 8139too" or whatever your module is. This should work, then you can just run "/etc/init.d/networking restart" to re-initialize your network. Run ifconfig -v to confirm.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.