Help - Search - Members - Calendar
Full Version: Newbie Hard Drive Problem - Rh 9
Linuxhelp > Support > Technical Support
I'm a total newbie to Linux, and just installed Red Hat 9 on my WinXP system (made a new partition, etc.) This may be a stupid question, but I can't seem to find an answer anywhere. I've searched through Google, and the Red Hat help files, but can't find my problem. I hope you can help :-)

Linux loads fine, into KDE, and most things seem to work fine, with a couple exceptions. The network won't work, but I found online help for that (nVidia onboard LAN isn't recognized, found a RPM that I think will fix it). The soundcard setup fails, but that's for a different post. The main PITA is that I can't access my other partitions at all from Linux (the ones I use in Windows XP). There are 2, the primary partition on my master HD and the sole partition on the slave drive. I can see the partitions in the hard drives manager from KDE, it reports their sizes correctly, but when I browse to /dev/hdd5 (one of them), it askes me what I should open it with, and won't let me do anything with it. No mount options, etc. at all. My CDROM and Floppy drives work fine, but I can't open files, browse, etc in the partitions I know are there. Is there a setting I can use from the GUI to fix this? (btw, same problem in Gnome)

The funny thing is, I can boot a different version of Linux, Knoppix, from a CD, and it works fine! I can browse the partitions, play MP3's, etc. (Still can't use the network though) I would think that simply browsing a normal hard drive shouldn't be a big problem! If anyone can help me with this, I would greatly appreciate it.
I will assume that your XP partitions are NTFS which RH does not include support for in their default kernel.

See this link to add ntfs support:
Hay, i'm just following up.

If this helps could you let us know as i'm writing a PAQ's page and so I'm asking as many people as I can to write how they sovled their question and how.


i would've had that same problem, but i got together with a friend of mine and i just moved all my files over to his computer, reformatted a partition that was NTFS to fat16/32 and then moved my files back over. though if you want to see those harddrives/partitions and the harddrive/partition with the windows os is NTFS, you may have to uninstall windows and start from scratch, reformat it as a fat16/32 and youre set. the just use this in the command line, as root:

[root:]fdisk -l

and find your partition/harddrive, and then do this:

[root:]mkdir /choosedirectoryname
[root:]mount -t vfat /dev/yourharddrive-partitionname /choosedirectoryname

then youll want to open your /etc/fstab file in an editor of choice (i use emacs) and add the same no. of lines as no. of partitions/harddrives you want mounted with linux.

the file "/etc/fstab":
/dev/hdb1     /uniac     vfat     defaults     0  0

then save that file.

also check this out: how i did it on my machine
Thanks for the replies! I knew that Linux had problems with NFTS, but I though that was limited to writing to the file system. I checked out the posted link, and will download the RPM for my kernel tomorrow and try it out (don't have access to my machine at the moment). Hope it works!

However, I'm still confused about one thing. I was unclear about my system partitions in my first post, sorry for that; here is my exact drive setup:
Master HD - 20GB; 12.5 for WinXP (NFTS), 7.5 for the three Linux partitions
Slave HD - 30GB; all one partition (FAT 32)
So, why can't I access my slave drive (/dev/hd5) in Linux?? I would think that, if it's a NFTS problem only, the FAT 32 HD should be readable. Or would one partition effect everything else also? Both drives are Western Digital, less than 2 years old. I'll try the RPM linked above, and let you know, but would really be interested in why this might be occuring on the slave drive too. Thanks again!
so do you have a gui?

if so, go to something like system settings, then hardware browser, then to harddrives. you should be able to see every harddrive with their partitions in there with their names.

also, you can try this.

login as root by logging out of your gui x-windows. if you just type su to login as root in your user name in the terminal, it wont recognize this command. you must be logged in as root. then open up a terminal. type:

fdisk -l

this will give you information regarding your partitions/harddrives as well.

tell us if this works.
OK, I figured out how to mount the FAT32 partition using
mount /dev/hdd5 /mnt -t vfat -r (Thanks for the link in the other thread!)
Now I can see that partition, so that's one problem fixed :-)

Still, two problems:

When I queried as to what my Linux kernel version was, it said 2.4.20-6. Unfortunatly, that isn't one of the ones listed on the website you linked in the other thread! Can I just use a later version RPM? (i.e. 2.4.20-8)? Or do I have to add a different version of the kernel? (No idea how to do that! :-)

Also, I can't play mp3's off of my FAT 32 partition, even though I can see them. When I double click from KDE, the player opens, but nothing happens. I installed xmms-mpg123-1.2.7-21.i386, linked from another post, but it still won't work. <sigh> Any suggestions?

Sorry for all the newbie questions, but I'm learning a lot with all the help. Thanks again!

(BTW, I'm using KDE, in answer to your question)
is your volume turned up? speakers plugged in?

make sure that you have the mp3 decoder selected as being active in your media player.

check the permissions on your harddrive/partition that your mp3's are on by doing this:

ls -l /yourpartition

this should spit out a line of info. the first 13 digits are your rights. the first digit tells you youre looking at a harddrive/partition, the next three give the rights of that harddrive/partition in respect to root, the next three are permissions of user, and the last three are permissions of other.

what are you logged into when youre trying to play the mp3's? root or a user?

go to a terminal, type in su, then your root password, and change that drive/partitions rights by typing this:

chmod 775 /yourpartition

that will give read/write/executable rights to root and user.

if that doesnt work, do the "ls -l /yourpartition" and post what it spits out at you.

hopefully one of these will work or help us find an answer.
> is your volume turned up? speakers plugged in?

Yep, the sound test plays fine when I try it. (Although the volume is low, even with the volume settings all the way up)

> make sure that you have the mp3 decoder selected as being active in your media player.

The default media played doens't seem to have an option for this; should I be using a different one? If so, which one? None of the play/ff/etc. controls work when I open the mp3's.

> what are you logged into when youre trying to play the mp3's? root or a user?

I tried both as user, and logged into root; neither work. I tried chmod 775 /dev/hdd5, and it still wouldn't play. But, I can open text files and Word docs from that drive! My output for ls -l /dev/hdd5 was:

brwxrwxr-x 1 root disk 22, 69 Jan 30 05:24 /dev/hdd5

Does that tell you what the problem might be? Thanks for the help.
brwxrwxr-x 1 root disk 22, 69 Jan 30 05:24 /dev/hdd5

i just wanted to see the first 13 digits. the first one says it's a harddrive...the next three are permissions for root. which has read/write/executable permissions. user has the same permissions, and other only has read and executable permissions.

did you try turning your volume up higher? you said it was really low...did you check the volume mixer too?

so if youre logged in as user or root, you should be able to play them...i dont know what youre using to play your mp3's, but i would get xmms and try that, that's what i use (it's like winamp). and then youll need the mp3123 decoder to listen to mp3's, and make sure that is active.

try this for xmms

and here for the mp3 decoder for xmms
I downloaded both RPM's, and tried to install them, but Linux said that they were already installed. So I tried uninstalling and reinstalling xmms, and what do you know, it worked! Cool. (Don't ask me why it didn't work the first time...)

OK, so now I can play mp3's and access my FAT32 HD from Red Hat, but NFTS is still unavailable. The link from the other thread, to RPM's for NFTS in Linux, didn't include one for my kernel (2.4.20-6). So can I use one for a later kernel (2.4.20-8, for example, wich IS avainable), or do I need to try aomething else? Any suggestions? (Also, I still can't connect to the network, but I'm working on that :-)

Thanks to everyone for helping a newbie; this is a great forum!
I'm glad you got your mp3s working... it wouldn't have worked 'out of the box' because redhat does not ship mp3 support in their xmms-mpg123 rpm (some sort of legality issue), but the one you downloaded does support it.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.