Help - Search - Members - Calendar
Full Version: Couple Of Problems!
Linuxhelp > Support > Technical Support
First, I must apologize for any noobie moves I will/have made. biggrin.gif

Anyway, my first problem comes with LAN connection. I have a Netgear MA101 wireless deal and I've set it up with all the proper atmel wireless drivers etc and it works fine except when I reboot. Upon doing so and coming back to Linux I'm unable to do anything connection wise unless I once again execute:

ifconfig eth0 ipadress up
route add default gw ipaddress

Now my question for this would be is there anyway to get it to stay for each time that I shut my system down? It's a bit bothersome!

My second question is in regards to installing the Java RE package. I've downloaded the software and ran it. What seems to have happened was a simple extraction of files to /usr/local/j2re1.4.1_02. What further steps need to be taken to have access to the java commands? The installation doc's on weren't too friendly to me.

Thanks in advnace,
Hiya Clueless.

To add a module into the kernal so it will boot up, you need to logg in as root (su if your in RH) and type the following.

"insmod <module>"

Now, I would try "insmod ifconfig eth0 <ipadress> up"

and see if that works . . . it might not. But if it doesn't you'll have to write a module on the network stuff. I'm not 100% sure how you do that but try the above first. I've no idea on your Java thing . . . but . . .

When you say you installed a JAVA thing do you mean a JAVA internet browser or are you talking about a prog that helps write Java?

a. If your a Java programmer thats great, I'm looking at setting up a programmers forum to this site, but I only html/xhtml. I'm looking at gettin' a group of people together just to chat about programming.

B. What did you download that you write java in? I tried a bit of C using a command line editor, but all my texts on C programming contained bugs so wouldn't compile so I could really load em!

Oh my apologies for such vagueness. The Java "thing" that I was reffering to was simply the Java 2 Platform ( When trying to install something earlier I ran into a problem; It required me to have the Java runtime environment installed thus enabling a supposed "java" command to execute the installation. After following the instruction set on the Sun website ( and rebooting, I was still unable to run the "java" console command.

Stumbling around through google searches I came across a page that I thought would help. One of the things it gave me to do was something along the lines of "ln -s j2re1.4.1_02 j2re". j2re1.4.1_02 is the directory name located in the /usr/local folder. j2re was some kinda of symbolic link it recommended?? Im not sure what that means or what that does but now when I get the /usr/local directory listing, the j2re is highlighted in red and flashing.

Im currently on the upstairs computer, but as soon as I step down again I will try your recommended cure for my lan woes. For now I'm gonna continue on my search, thank you for the help though. Sorry for the programming disappointment!
Hay, sorry that I couldn't help on the Java thing.

But if you ever take up programming or need help with html/xhtml (nothing with CGI scripts in it though, i'm waiting to learn that till i can write them in Java!) you know where I live!

Fixed the java problem! Came across a document that explained how to like the java/bin to usr/bin in order to get full access to the commands. Unfortunetly your insmod recommendation didnt work sad.gif

Looks like you'll have to write a module and then use insmod <newmod.c> and that'll work.

But I have no idea how to make a new module, but I'll hang around till someone else knows, and I'll learn as well.

there was something at (another very good linux forum) that talked about setting up a command where you just typed in a word and did a predefined command for you. try going there and searching for "alias upstairs" i think it was...
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.