Help - Search - Members - Calendar
Full Version: How To Login As Root
Linuxhelp > Support > Technical Support
warheros
i cant figure out how to login as root in rh9 w/ gnome. i mean when i try to access certain settings it asks me for the root password, but when im in the terminal i cant figure out how to be 'root' and type commands. it is baffling me.

help?!
echeng66
Did you try
su
It will prompt you for your password.
warheros
no, but i figured it out, thanks for the advice though. i just have it ask me who to login as at startup now, solves my problem pretty well. now im just trying to figure out how to mount a partition on a harddrive, i try to, and it says it cant, then it says, "are you sure youre not wanting to mount a logical partition instead of a drive?" or something like that...anyways ill figure it out...someway or another. my modem problem still calls to be fixed.
Jay-Jay
Hiya, Have you got this sorted?

Jay-Jay
michaelk
In a nutshell:
IDE drives are
hda - 1st controller master
hdb - 1st controller slave
hdc - 2nd controller master
hdd - 2nd controller slave
hde hdf ...

The partitions on the drives are numbered 1 - 64.
1 - 4 are primary partitions
5 and up are logical partitions

So hda1 is the 1st partition on the 1st controller master.

To see how your drives are partitions the commad (need to be root for this)

fdisk -l (thats a small L)

Then to mount

mount -t vfat /dev/hda1 /mnt/mnt_point

Of course mnt_point is the existing directory to mount the partition to and hda1 need to reflect the actual partition you want to mount.

see man pages for mount and fsab for further info.

To automatically mount a FAT32 partition you will need to add a line in the /etc/fstab (also need to be root)

/dev/hda1 /mnt/<mnt_point vfat user,umask=000 0 0
Jay-Jay
Wow, I learn something new everyday.

Thanks michaelk.

If this helps warheros could you let us know as i'm writing a PAQ's page and so I'm asking as many people as I can to write how they sovled their question and how.

Thanks

Jay-Jay
warheros
actually, i believe i just made it so when linux starts up, it prompts me who to login as, and i just login as root, because when i login as my own user (that's not root), it doesnt recognize the 'fdisk' function at all. it says something like "command not found". so yea, i just sign in right at the beginning as root and im set to go.

thanks for everyone's help!

from what ive learned thus far, this is the only way to be signed in as 'root' and have the abillity to use the 'fdisk' function. even in my other profile, i couldnt do
CODE
man fdisk
had to login as root from the get to; the very beginning, etc., etc.
warheros
as with the trouble i had with mounting my other partitions, this is how i solved it:

logged in as root

CODE
mkdir /eniac
mount -t vfat /dev/hdb1 /eniac


did that again for another partition.

opened file /etc/fstab (i believe...?) in emacs, and added two extra lines so that my partitions would be added on every reboot (if i didnt, they would not be mounted still after i rebooted my machine). something like this:

CODE
/dev/hdb1     /uniac     vfat     defaults     0  0
/dev/hda1     /eniac     vfat     defaults     0  0


then i saved that. problems solved!

i also changed the read/write/execute properties for myself by entering this in command line:

CODE
chmod 775 /dev/hdb1


that gave root full permissions, the group full permissions, and only read/execute permissions to anyone else.
Jay-Jay
Thanks that's great.

Jay-Jay
Medic6666
You really don't need to login at the start as root.

When you open a term session just type SU and then you password and you have root access.
You then type exit to leave root and go back to user.

This is a much more secure and safe way of doing it.

But hey ho each to their own biggrin.gif



Good Luck

Medic6666
warheros
just tried the "SU" command in another user that wasnt root, it works, but it still doesnt let me use the fdisk -l function. dont know why...the only ive found out to use it is to logout and login as root.
salazaar
If you login as a normal user, you can, in a console, login as the SuperUser (SU). This gives you the priority of root. Login as the SU, then access the GDM login controls. You can change your login settings from there.
chrisw
when you su to different users especially root...dont
forget to add the "-" for example to su to root type the following

su -

the "-" processes path information and other settings affecting root

same goes with other users
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.