Help - Search - Members - Calendar
Full Version: Help A New Install Gtk
Linuxhelp > Support > Technical Support
Ok, I'm trying to install a game that says it requires gtk2.0, not sure if it HAS to have this to work properly but I installed it, said oh you need gtk2.0, but the game install said it worked fine. So I run the game and it crashes after so often... 2-5 mins tops usually.


Ok so I goto install gtk and it tells me I need all these dependancies installed first, ok fine. I goto install the pango dependancies, dang it!!! I need glib 2.1.0 or I go and download 2.2.2. At first it gives me a problem, but I read the install, follow it exactly and it looks like it installed fine. Ok great! So I go back to pango.. start to configure... " ./configure " it get's to the end and says glib-2.1.0 or higher isn't installed or most likely is improperly installed. Oh great, so I try a few more times and still can't get it to work. I go back and forth between glib and pango, because doing the ./configure on pango is the only way I find out glib isn't working right, is there an easier and faster way? Is there a way to see exactly why it's not installed but seams to install fine? What am I doing wrong? I'm a noob remember!! It could be ANYTHING!! I'm installing this from my /home/username/Documents file mind you BUT I am su'd in as root, because well, I figure root is needed to install ANYTHING. Please point out where I am wrong in anything I said, I NEED to be corrected if I am to learn this wonderful os anytime this century. Appreciate you taking the time to even read this, thanx.
Okay, lets just try and clarify (I'm not sure I can help).

At present, your trying to run a game.

Your current problem is installing glibc ">"

Rite then let me have a lookie . . . Aha found something.

I suggest that you have a lookie on this site . . .

Please let me know your progress, i'll be writing a paq's page on this site soon(ish, bout a month) so I'd love to hear some follow up on how you got on.

Ok thanx for the quick reply.. I got as far as make install and I get an error... I get

libtool: install: warning: relinking `'
(cd /home/ghost/Documents/glib-2.2.2/compile/gobject; /bin/sh ../libtool --mode=relink gcc -g -O2 -Wall -o -rpath /usr/lib -version-info 200:2:200 -export-dynamic g boxed.lo gclosure.lo genums.lo gobject.lo gparam.lo gparamspecs.lo gsignal.lo gsourceclosur e.lo gtype.lo gtypemodule.lo gtypeplugin.lo gvalue.lo gvaluearray.lo gvaluetransform.lo gva luetypes.lo ../glib/ )
mv: cannot stat `': No such file or directory
libtool: install: error: relink `' with the above command before installin g it
make[2]: *** [install-libLTLIBRARIES] Error 1
make[2]: Leaving directory `/home/ghost/Documents/glib-2.2.2/compile/gobject'
make[1]: *** [install-am] Error 2
make[1]: Leaving directory `/home/ghost/Documents/glib-2.2.2/compile/gobject'
make: *** [install-recursive] Error 1

there were a few files I wasn't able to mv or cp because they didn't exists, the following are the files in question



What should I do now?
Okay, we are gettin' somewhere. I'm not a real big programmer (learning but not getting anywhere fast) but the lib files as far as I know are what makes any programme run and hold all the info on commands for the prog. So, missing a couple of lib files is like trying to start a car without petrol (gas), the contents there but theres no fuel.

As for getting this files let me have a lookie . . . well, if you google the files some of them comes up, but it will take time to find the files that you need.

I'm wondering if your install messed up somehow. If you got internet access (which i guess you have) then I suggest that redownload the glibc thingy.

I'm sorry i can be of much help and that i took a while to reply, but I'm cramming for a final on monday.

Let me know how you get on.

Actually I was using glib not glibc is there a difference? If so could I use glibc to fulfil the dependancy you think? As for these missing files do I search for them independantly and just place them in the files I was trying to move them and place and copy the others? I'm a complete newb to this kinda of process and unsure what my next move should be. All these dependancy problems and makes, make installs, ./configures is a bit much. I'm used to windows, you click install and it installs to the folder I specify. In linux, when I click make, make install and so forth. I have NO idea what it's doing and where it's putting stuff, if it is. Maybe I got in a bit farther than I should have at this point. *grins*

btw, good luck on your finals.
A new update.... now I can't even ./configure after redownloading glib, seams those files that the install guide you had me use said to move, it is trying to look for during ./configure

OUTPUT FROM ./configure

checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking whether make sets $(MAKE)... yes
checking for working aclocal-1.4... found
checking for working autoconf... found
checking for working automake-1.4... found
checking for working autoheader... found
checking for working makeinfo... found
checking whether to enable maintainer-specific portions of Makefiles... no
checking build system type... i686-pc-linux-gnulibc1
checking host system type... i686-pc-linux-gnulibc1
checking for the BeOS... no
checking for Win32... no
checking whether to enable garbage collector friendliness... no
checking whether to disable memory pools... no
checking for gcc... gcc
checking for C compiler default output... configure: error: C compiler cannot create executables
See `config.log' for more details.

config.log is a bit large or I'd a pasted it here. laugh.gif
Hiya. I don't know if they are the same thing, but certainly if the name is different I would assume that they have different content.

As for the log file, type

"grep "EE" config.log"
"grep "WW" config.log"

This 'should' put up the errors, if not have a look through the file for symbols that stand for error and warning, and replace the EE and WW for them.

That will list just the text that has EE and WW.

If i'm reading the file names right, glib stands for graphics libary. glibc stands for graphics libary C (for the programming language C) which will make a BIG difference.

Try finding the files you need with GOOGLE.

woohoo new update... I sort of got glib to install... I mean I got through the install just fine with no errors but I go to install my other dependancy of gtk.. pango 1.2 and I get this

*** Could not run GLIB test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means GLIB is incorrectly installed.
configure: error:
*** Glib 2.1.3 or better is required. The latest version of
*** Glib is always available from

If the glib 2.2.2 install was fine with no errors why is it telling me it may not be isntalled correctly?

EDIT: I did grep "EE" and "WW" for the config.log file and this is the output

FREETYPE_LIBS='-lfreetype -lz'

only "EE" gave an output tho.
Well that ment nothing to me. So i doupt that I can help, but someone might see that and know what your talking about!

Ok moving along.. slowly yet surely, lol. NEW UPDATE. One step closer baby!

After a repsonse in another forum I tried useing this idea of doing:

"export PKG_CONFIG_PATH=/usr/lib/glib "
and then

now I get this..

ecking for pkg-config... (cached) /usr/bin/pkg-config
checking for GLIB - version >= 2.1.3...
*** 'pkg-config --modversion glib-2.0' returned 2.2.2, but GLIB (2.2.1)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
configure: error:
*** Glib 2.1.3 or better is required. The latest version of
*** Glib is always available from
[root@localhost pango-1.2.0]# grep "EE" config.log
FREETYPE_LIBS='-lfreetype -lz'
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.