Help - Search - Members - Calendar
Full Version: Modem Help With Linux 9.0
Linuxhelp > Support > Technical Support
warheros
i have been trying to get a dial-up internet connection going with my other box, which dual-boots with redhat 9.0 and microsoft windows xp pro, which the latter has completely frozen up and i need to do a repair install (so i hear). i use ACD as my ISP which has no software of its own. so ive been trying to learn stuff about the linux os i put in recently since i have been getting annoyed with windows. anyways, i need some modem help, i dont know what kind of modem it is, i cant find the information anywhere. i have a dell dimension 4300 with the standard dell datafax v9.0 56k modem.

ive made "connections" with it, and gotten to the point where redhat says its dialing but never changes from telling me it's "establishing a connection" or whatever. help will be greatly appreciated. thanks in advance.

also, i would like to know how to access my other partitions i have that windows uses, as i have a partition that is all music and i want to do something other than just look at my redhat desktop, i.e., listen to some music. i heard there was a visual interface that was like windows' "windows explorer" to view files and such...again thanks in advance

~warheros

email: warheros@yahoo.com (may be easier)
Jay-Jay
Well Hello!

Okay, I don't know how to solve all your problems at once, but I can make a start.

To get you linux OS to 'see' other partions, firstly if you don't know what partions you have on your computer type

"fdisk -l /dev/hda"

For arguements sake lets use my partion details, I get

/dev/hda1 <system> Fat16
/dev/hda2 <system> Linux

From this I can tell that hda2 is my linux partion and that's already mounted so, i want to mount hda1, but first you need to make a place to mount them to. You do this by;

"mkdir /<where you want it and what name>"

lets say we put it in

/hdmount/music

Then type

"mount -t vfat /dev/hda1 /hdmount/music"

And that will mount it.

As for your question about you GUI, there's loads out there, there are some that look like "windows" but I'm not sure what it's called (or infact why you would want it to look like windows).

Jay-Jay
warheros
i tried your commands in the console and it said something like "command not found" or something of the sort. then i just tried to type "dev/hda1" and it said "permission denied"

i have no idea. yea...so i need some help on that.
Jay-Jay
Hiya, sorry my bad. (I get told off for doing this) I forgot to say that you need to be logged in as root. I'm just learning my way around a console on an old laptop that's in the corner of my room and I always log on as root because it's a standalone (no network / internet or CD drive for that matter).

If you can, try loggin on as root (if you have permission). If you can't loggin as root i.e. it's not your machine, I have no idea, but theres plenty of guys around here that will help.

Let me know how you get on.

Jay-Jay
warheros
how do i log in as root? i am the "admin" of my machine, and i know the user/pass for root but im not sure how to switch to it.
Jay-Jay
Hrmm.

I'm not sure about different distro's, i run my stuff from the command line. If you get to a command line and your logged in, type logout (or logoff if logout doesn't work) then you should type in root then you password.

I'm not sure though, admin and root might be the same thing. I'm new to this whole thing!

Jay-Jay
warheros
yea i cant figure that out...i tried "logout" and "logoff" and "exit", and the only thing they did was to exit the terminal program. i am supposed to be doing this in the "terminal", correct?

so i tried "login as root" which worked, but then i put in login: root & password: my password and it said not valid and i tried a bunch and it still didnt work. so i dont know what's up.
Jay-Jay
Yeah, because of the way i work (all root based) i don't know any way around it.

I don't have a GUI (graphic user interface) on my laptop, so i'm running EVERYTHING from a command line. Seems like you've got the right command from logging on as root. Just the password. Now, I know passwords are case sensitive etc etc, so I really don't know, maybe it's just a layout issue, I really am a bit stumped (also v.tired!).

If you can't log in as root i'm guessing that my way of trying to solve it won't work, and I don't know any other way. If this is the case then i'll stay watching this post and see the results, as there are many others that can help you better, and we'll both learn!

Jay-Jay
Jay-Jay
Sorry, i'm falling asleep at the keyboard.

I'm off to bed.

Sorry I couldn't have been more helpful tonight. And I'll read up on your posts tomorrow morning.

Jay-Jay
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.