Several months ago, I switched from windows to Linux. I used Redhat 8.0 with Gnome. Since then, I've tried installing a lot of stuff (mostly using the make process). I even managed to switch window managers (fluxbox). If software installation failed, it was usually due to not finding libraries related to GTK or glib. So recently I figured... why not install another GTK? I downloaded it and started going through the dependencies... Glib installed fine, but when I try to install, it can't find any glib. So, now I've got two version of glib on my system and the programs I'm trying to install can't find either of them. One of them is rpm, and one is from source.
In addition, I feel like the system is a mess... I've got two kernels (tried to make a second one... kinda bloated and doesn't load the mouse properly), two apache's(one rpm, one source), one and a half wine (which doesn't work) and two gcc's!
What a mess!
What can I do? I'm even considering reinstalling using a different distrobution (perhaps gentoo or slackware).
How can I go about a process to clean things up? Would it be easiest to back up my personal files and do a fresh install?