Help - Search - Members - Calendar
Full Version: Aureal Vortex 2 8830 With Slackware 9
Linuxhelp > Support > Technical Support
Toraton
I'm a new Slackware 9.0 user having more than a little trouble getting my Aureal Vortex 2 8830 to work with GNOME, KDE, or with linux in general. When I checked my boot log, it says that I compiled it with a version 2 compiler, yet my copy of GCC is 3.2.2. I have posted the relevant part of my syslog, any help is appreciated.
CODE
Jun 14 16:24:25 lithedark insmod: /lib/modules/2.4.20/drivers/sound/au8830.o: The module you are trying to load (/lib/modules/2.4.20/drivers/sound/au8830.o) is compiled with a gcc version 2 compiler, while the kernel you are running is compiled with a gcc version 3 compiler. This is known to not work.
Jun 14 16:24:25 lithedark insmod: /lib/modules/2.4.20/drivers/sound/au8830.o: insmod char-major-14 failed
Jun 14 16:24:26 lithedark insmod: /lib/modules/2.4.20/drivers/sound/au8830.o: The module you are trying to load (/lib/modules/2.4.20/drivers/sound/au8830.o) is compiled with a gcc version 2 compiler, while the kernel you are running is compiled with a gcc version 3 compiler. This is known to not work.
Jun 14 16:24:26 lithedark insmod: /lib/modules/2.4.20/drivers/sound/au8830.o: insmod char-major-14 failed
Jun 14 16:35:38 lithedark insmod: /lib/modules/2.4.20/drivers/sound/au8830.o: The module you are trying to load (/lib/modules/2.4.20/drivers/sound/au8830.o) is compiled with a gcc version 2 compiler, while the kernel you are running is compiled with a gcc version 3 compiler. This is known to not work.
Jun 14 16:35:38 lithedark insmod: /lib/modules/2.4.20/drivers/sound/au8830.o: insmod char-major-14 failed
Jun 14 16:35:43 lithedark modprobe: modprobe: Can't locate module char-major-10-134
Jun 14 17:05:01 lithedark insmod: /lib/modules/2.4.20/drivers/sound/au8830.o: The module you are trying to load (/lib/modules/2.4.20/drivers/sound/au8830.o) is compiled with a gcc version 2 compiler, while the kernel you are running is compiled with a gcc version 3 compiler. This is known to not work.
Jun 14 17:05:01 lithedark insmod: /lib/modules/2.4.20/drivers/sound/au8830.o: insmod char-major-14 failed
Jun 14 17:05:03 lithedark insmod: /lib/modules/2.4.20/drivers/sound/au8830.o: The module you are trying to load (/lib/modules/2.4.20/drivers/sound/au8830.o) is compiled with a gcc version 2 compiler, while the kernel you are running is compiled with a gcc version 3 compiler. This is known to not work.
Jun 14 17:05:03 lithedark insmod: /lib/modules/2.4.20/drivers/sound/au8830.o: insmod char-major-14 failed
Toraton
By the way, insmod -f au8830.o does not help, it just turns out a whole lot of unresolved symbols. Here:
CODE
# insmod -f au8830.o

Warning: The module you are trying to load (au8830.o) is compiled with a gcc
version 2 compiler, while the kernel you are running is compiled with
a gcc version 3 compiler. This is known to not work.
au8830.o: unresolved symbol unregister_sound_dsp
au8830.o: unresolved symbol unregister_sound_midi
au8830.o: unresolved symbol register_sound_dsp
au8830.o: unresolved symbol register_sound_mixer
au8830.o: unresolved symbol unregister_sound_mixer
au8830.o: unresolved symbol unregister_sound_special
au8830.o: unresolved symbol register_sound_special
au8830.o: unresolved symbol register_sound_midi


The troubleshooter says:
CODE
Problem: I get "unresolved symbol" errors during the compile, install or when I
        try to load the driver.
Solution: Rebuild your kernel with Sound Support (soundcore) built in -- not as
         a module.


Any help is appreciated.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.