Help - Search - Members - Calendar
Full Version: Mounting
Linuxhelp > Support > Technical Support
miken
Hi to all.

I have trouble mounting a fat32 partition onto RH 8.0 with /etc/fstab.

I placed this line in /etc/fstab:
/dev/hdb5 /mnt/windows vfat umask 0 0

On reboot, I got this error when the partitions were being mounted:

"wrong fs type, bad option, bad superblock on /dev/hdb5,
or too many mounted file systems"


When I do this:
[root@faith8 mnt]# ls
cdrom cdrom1 floppy windows
[root@faith8 mnt]# mount -t vfat /dev/hdb5 windows

The partition is mounted and I can access it just fine. Any clue??
Jay-Jay
Hiya, Could you do a favour and copy the whole of your fstab file up here? I could hasard a guess but without seeing what it is that you've got in the complete file I can't really help.

Jay-Jay
miken
Thanks for your offer.

After reading up on 'umask' on forums and how tos, I thought it was the correct option but after many hrs, I reluctantly tried using the 'defaults' option. This worked but I don't know why.

Changed:
/dev/hdb5 /mnt/windows vfat umask 0 0

to:
/dev/hdb5 /mnt/windows vfat defaults 0 0
Jay-Jay
Oh thats great. I'm glad that you've put the solution up here. Sorry i couldn't put any solution straight away.

I'm also having problems with my fstab file, in the fact that the absence on any data in the file and the inability to write over it i'm a little stuck.

Jay-Jay
michaelk
To allow users to read / write to the vfat partition.

/dev/hd5 /mnt/windows vfat user,umask=000 0 0

jay-jay:
Need to be logged in as root to write to anything in the /etc directory.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.