Help - Search - Members - Calendar
Full Version: Ethernet Tcp/ip Issues
Linuxhelp > Support > Technical Support
DrGannon
I have a fresh install of Red Hat 9.
Shuttle ak35gtr2 MB
3com 3c905b nic
D-Link DL-604 (residential gateway) Router
Card works fine in win2k and I'm using it right now to type this message in win2k.

Red Hat detected the card and assigned it eth0.
Card is supposed to be using DHCP to get info right of the router.

When attempting to activate the card from the config panel or during boot I get an error that it was unable to get IP info, link error, check the cables.

The router is 10baseT I think, and i have a sneaky suspicion that the card is defaulting to 100mbit. How do I force the card to either autonegotiate or stick to 10mbit.

I tried editing the /etc/modules.conf and adding "media_select=1" and "full_duplex=0" to the 3c95x line with no change same error.

It has been years since I used HPUX and this is the first time I've tried to install any version of linux. Any help would be appreciated.

All other hardware seems to have been detected and sound etc. is working great.

Thanks for your help!
Jay-Jay
I'm most likely wrong, but does the router work under 2k? I mean your saying that the card is defaulting to the wrong settings, could it be that your router isn't set up right? If it works under 2k it's unlikely to be the problem, but just askin'.

Jay-Jay
DrGannon
yep everything works perfect under win 2K

Thanks for asking.
Jay-Jay
Well I mite be able to help some more . . . lets have a go.

try

"lsmod", this will list you loaded modules, see is you device is there if no, carry on, if your using 2 or more network cards, ensure they are all there.

"modprobe -t drivers/net *" this will load all network driver modules, or try them until it finds the rightone

and then try

"lsmod" again and see if it's there, it should be.

Let us know.

Jay-Jay
michaelk
It may not be the card. I have the same problem with a windows DHCP server. Maybe just the startup script

Try this command as root
dhcpcd
or
pump

Now check the output of
ifconfig

You should see a line for eth0.

I haven't figured out what to change yet in the script.

You can also configure the card manually just to see if it works.

ifconfig eth0 xxx.xxx.xxx.xxx netmask xxx.xxx.xxx.xxx up

Then check again with the command
ifconfig
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.