Help - Search - Members - Calendar
Full Version: Virtual Height?
Linuxhelp > Support > Technical Support
ahills
when i try to stat x, it says my virtual height is zero and needs to be 128... ??? how do i change the virtual height? it's not in the XF86Config file!
Jay-Jay
You could try "grep "EE" | /var/log/XFree86.0.log" and then "grep "WW" | /var/log/XFree86.0.log" and let us know what it says. Also, if you could put up the bit about your g'c (Graphic's Card) and monitor from your XF86Config(-4) we might be able to help you.

What g'c and monitor are you using? I've seen some stuff on google that might be able to help you. . . .

Jay-Jay
Jay-Jay
You can change the virtual height, but if you are unsure of how to put it in your config, you could try

"dpkg-reconfigure xserver-xfree86"

I would set your screen to low resolutions and a bit rate of not less than 8 (X doesn't like it otherwise)

you can select the veiw height in the reconfigure prog

Jay-Jay
ahills
grep "EE" | /var/log/XFree86.0.log:
CODE
/var/log/XFree86.0.log: line 2: syntax error near unexpected token `('
/var/log/XFree86.0.log: line 2: `XFree86 Version 4.3.0 (Red Hat Linux release: 4.3.0-2)'

grep "WW" | /var/log/XFree86.0.log:
CODE
/var/log/XFree86.0.log: line 2: syntax error near unexpected token `('
/var/log/XFree86.0.log: line 2: `XFree86 Version 4.3.0 (Red Hat Linux release: 4.3.0-2)'

my XF86Config-4 file (i think this is the part about the g'c and monitor):
CODE
Section "Monitor"
       Identifier   "Monitor0"
       VendorName   "Monitor Vendor"
       ModelName    "Monitor Model"
       HorizSync   31.5-48.5
       VertRefresh 50-70
       Option "dpms"

       # -- 1400x1050 --
       # 1400x1050 @ 60Hz, 65.8 kHz hsync
       Modeline "1400x1050"  129   1400 1464 1656 1960
                             1050 1051 1054 1100 +HSync +VSync

       # 1400x1050 @ 70Hz, 76.8 kHz hsync
       Modeline "1400x1050"  151   1400 1464 1656 1960
                             1050 1051 1054 1100 +HSync +VSync

       # 1400x1050 @ 75Hz, 82.3 kHz hsync
       Modeline "1400x1050"  162   1400 1464 1656 1960
                             1050 1051 1054 1100 +HSync +VSync

       # 1400x1050 @ 85Hz, 93.2 kHz hsync
       Modeline "1400x1050"  184   1400 1464 1656 1960
                             1050 1051 1054 1100 +HSync +VSync

EndSection

Section "Device"
#   Option     "Rotate"
#   Option     "pciBurst"
#   Option     "ShadowFB"
#   Option     "NoStretch"
#   Option     "LcdCenter"
   Option     "externDisp"
   Option     "internDisp"
#   Option     "noMMIO"
   Option     "SWcursor"
#   Option     "NoAccel"
#   Option     "NoLinear"
   Option     "XaaNoScanlineImageWriteRect"
   Option     "XaaNoScanlineCPUToScreenColorExpandFill"
    Identifier   "NeoMagic 128XD (laptop/notebook)"
       Driver       "neomagic"
       VendorName   "NeoMagic 128XD (laptop/notebook)"
       BoardName     "NeoMagic 128XD (laptop/notebook)"
       
       #BusID
EndSection

Section "Screen"
    Identifier   "Screen0"
       Device       "NeoMagic 128XD (laptop/notebook)"
       Monitor      "Monitor0"
    DefaultDepth    24

    Subsection "Display"
           Depth       24
               Modes       "1024x768" "1024x768"
    EndSubsection

EndSection

my screen is a laptop screen on a Compaq Presario 1245 and the g'c is the one that works.
Jay-Jay
It doesn't look like those errors and warnings have anything to do with the problem, althought errors and warning can be fatal to X (I.e. not letting it run) others arn't fatal and X will run anyway.

Also in you config file there isn't a "Viewport" section for you screen. Now, i'm not saying this is the problem but it might be.

My version of X doesn't need the viewport (which i'm guessing is the virtual height) but if you run

"dpkg-reconfigure xserver-xfree86"

One of the sections is your virtual screen size. Personally I don't like it bigger than the resolution, but thats something that you might like to play with, I suggest making a backup of your config files before doing this just in case it misses or messes some things up (it hasn't for me in the past but in case you've made some changes to it yourself these will be lost as it makes the config files from scratch (i think)). This option will give you the viewport line in your screen settings.

I don't know how to control the viewport line, but to add it direct to your config file, goto the the secion "screen" subsection "Display" and at the bottom, just before EndSubSection, put in "ViewPort 0 0"

so your screen section reads; ""

Section "Screen"
Identifier "Screen0"
Device "NeoMagic 128XD (laptop/notebook)"
Monitor "Monitor0"
DefaultDepth 24
Subsection "Display"
Depth 24
Modes "1024x768" "1024x768"
ViewPort 0 0
EndSubsection
EndSection


If it is an error with the virtual screen size, which it might not be, but it's my best guess, these methods might sort it out. On the otherhand if it's not that it's the virtual screen height that it's complaining about, it's ruled out the possibility.

Jay-Jay
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.