Help - Search - Members - Calendar
Full Version: Where Is Xine?
Linuxhelp > Support > Technical Support
beni
I installed xine ( now which version was it exactly, 1.0.0 I think) using the following commands - ./configure, make, make install. I guess it installed fine as I didnt get any error msgs after a long long compilation. Then I dont know where it has been installed and how to run it. Tried typing xine at the command terminal but seems like there's no command as such.
So could anyone tell me where could it have gone and how to run it. And how to create a link for it on my desktop. And why exactly are source files so tiring. Everytime I compile ( install) a src file, I just dunno where it goes.
blackphiber
Well I don't really know where xine went, um, it should work the way you did it. I reccomend you try apt-get, I am assuming your using Red Hat so you can go to www.freshrpms.net and click on your distro, go download apt-get install (as root) rpm -ivh then run apt-get updat then apt-get -f install then apt-get install synaptic then type synaptic and find xine, worked like a charm for me, way to go debian people with apt-get! hope that helped and worked.
andrewjenkins
There are two possibilities that come to my head:

Did you download and install both xine-lib and xine-ui? Xine-lib is the set of libraries xine uses to play mpegs, avis and the like, while xine-ui is the program that uses the libraries. You have to have both, and you have to install xine-lib and xine-ui.

Next possibility - you installed them to a location your distro doesn't look in. if you just type in ./configure, then most configures will install by default to /usr/local - so xine would be /usr/local/bin/xine. Most "core" applications are installed to /usr (where appplications should be installed is kind of a religious issue for some linux users, but this is your system, so you can put xine wherever you want). I use this command for most of my source builds:

./configure --prefix=/usr && make && make install

This would install the xine executable as /usr/bin/xine. The xine libs would be found in /usr/lib.
Hemant
or use command..
$locate xine
or
from / directory enter command
$find . | grep xine

to findout, where ur xine is hiding...

for the long time of compilation, all i can say is we can't help.
beni
Umm...I think I installed both the lib and the ui cuz first of all the package(.tar I think) was in a Linux tools cd. And I dont think they would distribute an incomplete package. Anyway, I tried finding xine but I dont seem to have any executable named xine anywhere in / but there is one named xine-config, of whihc I cant makeany heads or tails. I will try and get apt-get and lets see if something works out.
Hemant
i have told enter command $find . | grep xine so that it will find xine in all directories.
anyway what was the output of command $locate xine

but i will make a guess,if xine is installed in ur system then xine executable must be in
/usr/bin or /bin or /usr/local/xine/bin

if it is not in these directories and both the above mentioned command failed to give any location of xine then i can say for sure that xine is not installed in ur computer.
beni
$locate xine yielded something like
/usr/local/xine/...
.....
/../../....xine-config

Well, the point is that there seems to be no executable by the name xine. And yes I installed apt and synaptic as well. It couldnt locate xine either. I am pretty sure that I had installed xine, but then even I am unsure about its presence now. After all, where could it just vanish like that.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.