Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Using Mkdir In /usr/local, i can't create a directory in /usr/local
00420
post May 29 2003, 10:08 PM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 1
Joined: 29-May 03
Member No.: 907



I am very new to Linux. I've been trying to install Adobe Acrobat Reader today, but when I run the installation script it says "mkdir: cannot create directory `Acrobat5': Permission denied".

So, then I tried to create the directory myself (instead of having the script do it). But, I got the same message. Then I tried doing it from my root user, and I still got the same message.

I using the chmod command so that permission would stop being denied, but when I do that it says "chmod: changing permissions of `local': Operation not permitted"

What am I doing wrong?
Go to the top of the page
 
+Quote Post
Corey
post May 30 2003, 09:16 AM
Post #2


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 1,254
Joined: 21-September 02
From: St John's, Newfoundland, Canada
Member No.: 3



Linux runs on permissions. Regular users are not permitted to create files anywhere but there home directory and /tmp directory (maybe others, depending on installation). In order for you to install acrobat into /usr/local , you need to be root. There are two ways to do this, either A) type "su" at the command prompt and enter your root password, this will log you in as root and allow you to install anywhere in the system. Or cool.gif install the sudo package and read the documentation. A quick fix would be just to "su" and install the package, and then immediatly log out again.


--------------------
Corey Quilliam
(former) Linuxhelp.ca Administrator
cquilliam-AT-gmail-dot-com

Want to help out Linuxhelp.net? Check out our Linuxhelp Wiki and see if there are some articles you would like to submit!!

--
Ubuntu 8.04 64-bit - Work Laptop (HP-Compaq NC6400 Core2)
Kubuntu 8.04 64-bit - Desktop (HP m8120n QuadCore)
Ubuntu 6.04 - Server (I'm not upgrading this baby until support runs out in 2012) (Some old POS dell)
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 20th October 2017 - 08:25 PM