Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )

Advanced DNS Management
New ZoneEdit. New Managment.


Sign Up Now
> Need help with a netgear wna3100 wireless usb adapter
post Dec 23 2011, 02:26 AM
Post #1


Group: Members
Posts: 25
Joined: 6-May 11
Member No.: 15,293

I am triple booting with Win XP Pro, Win 7 Ultimate and Ubuntu 11.10, everything is fine except I have no internet in Ubuntu while I am using the Netgear WNA3100 Wireless USB adapter.
I have the "ndiswrapper" tarball on my desktop and in a folder located in my home/wireless driver folder (a folder I created), also in this folder is the extracted files from the tarball and the 4 broadcom .inf and .sys files for this adapter, 32 bit and 64 bit I believe.

I cannot get ndiswrapper to install at all. I read somewhere to install "windows wireless driver program" (I am assuming this meant ndiswrapper) then point the program at the .inf file, (in my case the 64 bit version) and it should work.

But I cannot find an installer in ndiswrapper, what am I doing wrong.

I had exactly the same problem with my wna3100 and ubuntu 11.04 After two weeks of trying all suggestions I could find on the net, I succeeded. I hardly know anything about linux and found it quite simple. You just need the right driver.

Do the following step by step:

-plug in the wna3100

-open the terminal and type: lsusb

-hit enter, you should see something like this: Bus 001 Device 002: ID 0846:9020 NetGear, Inc.

if the answer is yes go on with the following

create a folder somewhere you could find it easily (name it wifi driver or so)

download the driver from here: (just copy the url, paste it in your web browser and hit enter if the link doesn't work)

-You will get a box that ask to open or save the driver file

-open it with whatever program you use to unzip (or save it somewhere and unzip it from there)

-unzip it to the folder you created in the first step

-right click both .inf files, go to tab 'rights' and click on the make file executable box (mine is in dutch so I don't know if the translation is right)

close that window

do the same for the .sys files
now open the windows wireless driver program (download it from ubuntu software center if you don't have it)

browse the .inf file with that program and click install.
never erase the folder where the .inf and .sys files are found
pull out the wna3100
reboot your computer
plug in the wna3100, when it stops blinking open the network manager.
You should be able to see your wireless network.
if yes, then jump up like me and shout yeehaah (or something alike)
if not, i feel really sorry for you, but somehow this worked for me and my ubuntu 11.04

I also tried this:

clay@clay-comp2:~$ sudo apt-get install ndiswrapper-common
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package ndiswrapper-common

As you can see this didn't work.

Other things I have tried:

clay@clay-comp2:~$ sudo lshw -c network
[sudo] password for clay:

PCI (sysfs) shows or does nothing

clay@clay-comp2:~$ iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

Here is your list of items you wanted, I couldn't paste them here, the forum would not let me, said it was too long.
Paste from Clayman1000x at Fri, 23 Dec 2011 08:29:51 +0100

I could really use some help putting a package together.

Case: Thermaltake Commander MS-I Snow Edition Tower Case
MB: Foxconn
CPU: AMD Phenom II 965 Black Edition 4 core
DVD: Pioneer Internal 15X Blu-Ray Burner
Ram: Corsair Vengeance 2 * 8GB (2x 4GB), DDR3-1600MHz
HDD: 500g WD Caviar Blue 1t WD Black, 4t Seagate
Video Card: Asus HD7750
OS: Win7 Ultimate w/ Ubuntu 12.04, Cairo-Dock
Go to the top of the page
+Quote Post

Posts in this topic

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:


RSS Lo-Fi Version Time is now: 18th July 2018 - 12:14 AM