Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )

Advanced DNS Management
New ZoneEdit. New Managment.


Sign Up Now
Reply to this topicStart new topic
> Ubuntu overwrote external drive, Serious issue, please help!
post Dec 12 2011, 08:21 PM
Post #1

Whats this Lie-nix Thing?

Group: Members
Posts: 2
Joined: 12-December 11
Member No.: 15,752

I've tried finding help on the Ubuntu forums, but no has replied to my post, so I want to see if anyone here can help me.

Basically, Ubuntu seems to have overwritten the partition on my external drive while booting. I can't fathom why it would do that; it happened after an update, so perhaps it was a command related to the update.

I created a TrueCrypt encrypted partition on my external 1 TB drive under Windows, then switched OS's to test for any issues. (TrueCrypt's volumes are cross-platform.) While booting into Ubuntu (after applying an update in a previous boot), I noticed two extra lines of text displayed that I've never seen before while booting Ubuntu. They appeared after the GRUB menu ("loading from (hd0,4)" etc.) and before Ubuntu's login screen. It was stupid I know, but I neglected to write them down.... I do not remember exactly what they said, but I DO know they referred to my external drive. I think they included the command "dd", but my memory is too fuzzy to remember for sure.

After logging into Ubuntu, I tried mounting the drive in TrueCrypt. It basically said the volume was corrupted. I restored the volume header with a backup, which allowed me to mount it, but the internal filesystem was RAW. (Previously had been NTFS.) Furthermore, from what I could determine, not only had the encryption header and filesystem been corrupted, but the PARTITION had been destroyed as well. Disk utility in both Ubuntu and Windows indicated the drive was unpartitioned.

Nothing on the drive was important -- I was testing after all. I tried reproducing the problem, but haven't been able to. (This is why I suspect the update had something to do with it.)

I'm not familiar enough with Ubuntu to know why it might write to an external automatically. But this is a serious issue -- I do NOT want an encrypted drive full of important information to become corrupted in the future. I would like to know how this problem occurred so I can prevent it in the future.

Distro: Ubuntu 10.04.3 Lucid Lynx
Other OS (GRUB Dual Boot): Windows XP Pro SP3
Intel Celeron 2.3 GHz
NVIDIA GeForce FX 5200 (256 MB)
80 GB internal HDD (divided for each OS)
160 GB internal (storage)

For other details, just ask.
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:


RSS Lo-Fi Version Time is now: 17th July 2018 - 05:01 AM