Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )

Advanced DNS Management
New ZoneEdit. New Managment.


Sign Up Now
Reply to this topicStart new topic
> VNC Problems
post Mar 14 2011, 06:13 PM
Post #1

Whats this Lie-nix Thing?

Group: Members
Posts: 1
Joined: 14-March 11
Member No.: 15,164

OK, It's rare I ask for help I normally just stumble about the Internet and find the answer myself but this one has me stumped.

I am currently running BackTrack 4 under a VM on my desktop. I want to be able to access this via VNC on my Windows XP laptop.

The connection type is bridged (for vm) so it should work exactly like a normal networked computer. I start 'vncserver' and all is good. The port 5900 is forwarded on my router, and apparently BackTrack 4 firewall is off by default (and I aint' turned it on). I try to connect from the windows box and I get connection refused. I've netstat -ant | grep LISTEN, and their is no VNC. So it appears that this could be the problem, however with SSH it was listening but it was still refusing connections from the windows machine. I did a quick check using an online VNC checker that was posted on another help forum post somewhere and it detected that the VNC was up and accepting connections. This raises this question why can I not do this locally. I have even added the windows IP to /etc/hosts.allow.

I'm stumped as to what is going on, but I have determined that for some reason it does not appear to actually be starting the service, and when it was (1 reboot ago) I still got connection refused. I have also tried using DynDNS, ext/int IP Add, Comp Name when connecting and I have tried TightVNC and RealVNC viewers on the windows side but neither work.


I installed webmin and made sure that my IP-tables were not blocking the connection (They wern't)

I have now downloaded KDE remote desktop and we finally have a connection listening on 5900 (Must be a problem with the other VNC) but of course when I try to connect to this I get an error. This time it is the Backtrack machine closing the connection and the error I recieve in TightVNC (Client) is SocketIPv4 error while reading. Now I don't know why this is happening apparently TightVNC client supports both IPv4 & 6. Even more confusing is that the address I have set up is an IPv4 address and uses IPv4 as its protocol type. I tried square bracketing the address in RealVNC (':' is used in RealVNC but also in IPv6 so obv issues arise) this still left me no joy.

Any ideas on how to determine all VNC software installed (I installed a few) and removing them on BackTrack? I am going to try completely removing all VNC server software (I feel there may be clashes because non of them are listening unlike KDE RD) and reinstall vncserver from scratch. How would I go about detecting and removing all VNC server files for all softwares installed?

I think that's everything, I appreciate everyones thoughts.

Peace out

Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:


RSS Lo-Fi Version Time is now: 16th July 2018 - 04:06 AM