Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )

Advanced DNS Management
New ZoneEdit. New Managment.


Sign Up Now
Reply to this topicStart new topic
> using dd to image network drive
post Jun 18 2009, 12:16 PM
Post #1

Whats this Lie-nix Thing?

Group: Members
Posts: 1
Joined: 18-June 09
Member No.: 14,510

Let me try to explain my situation here. I've got a network drive with one Windows and one Linux partition on it. The only way I can access this drive is by mapping to it over the network in Windows or using mount in Linux.

The drive has a 32Gb capacity and the partitions are roughly evenly split in that space. I have an identical drive that we'd like to use as a duplicate. However, the two drives must be identical.

I had previously read about using dd to do a bit by bit drive image so I thought I'd give that a shot. I booted a backtrack4 live cd and mounted the drive like so.

mount -t smbfs // /mnt/networkdrive

The drive appears to mount correctly as I can browse around and see the files in that partition. Then I tried to use dd to copy an image of the drive to an external hard drive.

dd if=/mnt/networkdrive of=/mnt/externalhdd/NAS_image.img conv=noerror,sync

Now here is where the problems start. I expected this to take a few hours since this was a 32Gb drive. It ended up taking almost 24... and it only stopped after 200Gb because my external hard drive filled up. Obviously I've done something wrong here.

Having put some more thought into it, I also have some other concerns dealing with the partitions. I can only mount one of the partitions, but I need to make sure I copy both of them. Will my method work for copying both partitions? Additionally, why was the file size 200Gb+ for a small 32Gb drive?

Hopefully you guys can help me out here and sorry if anything I said was too offensively noobish.
Go to the top of the page
+Quote Post
post Jun 19 2009, 06:58 AM
Post #2

Its GNU/

Group: Support Specialist
Posts: 1,807
Joined: 23-January 03
Member No.: 360

Never tried the dd command over the network and not sure what would happen. I would use the rsync command instead.
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:


RSS Lo-Fi Version Time is now: 15th July 2018 - 02:55 PM