Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
> Messed up MBR and GRUB
Nighthawk4900
post Apr 27 2009, 10:48 AM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 5
Joined: 27-April 09
Member No.: 14,427



Background:
I had windows xp pro working perfectly fine. Recently I got a CD for kubuntu 8.10 and I figured I'd try it out. I checked my partitions, and it turned out that I already had two partitions. One partition where windows was install and then a smaller secondary partition that I wasn't really using before. I figured I'd install Kubuntu to that partition. Well I installed and everything worked fine... except for the fact that the Windows installation was not recognized by Grub and therefore I could no longer boot into Windows. I tried by adding an entry into the grub file for windows following suggests from other forums where people had similar problems, but that didn't work either. I guess I got desperate at this point and tried a bunch of things, but nothing worked. Furthermore, now grub doesn't load either, so basically nothing works.

I tried to use the XP recovery CD but even that isn't recognizing my XP installation now. =( It also keeps asking for an administrator password, and says the pw I enter is wrong. Anyways...

I'm on an ubuntu live cd at the moment. I used gparted to check out the partitions and oddly, there is 7mb unallocated space at the beginning, followed by the 253 gb ntfs (XP) partition, then a 25gb ext3 partition where i installed Kubuntu, and finally a 7mb unallocated space.

CODE
ubuntu@ubuntu:~$ sudo fdisk -l

Disk /dev/sda: 300.0 GB, 300090728448 bytes
240 heads, 63 sectors/track, 38764 cylinders
Units = cylinders of 15120 * 512 = 7741440 bytes
Disk identifier: 0x00000001

Device              Boot      Start         End      Blocks         Id     System
/dev/sda1             *           2          38764   293048280    f       W95 Ext'd (LBA)
/dev/sda5                          2          35217   266232928+   7    HPFS/NTFS
/dev/sda6                     35218       38763    26807728+   e     W95 FAT16 (LBA)
ubuntu@ubuntu:~$



It should be noted, I was able to mount the ntfs partition and am able to access all of my data. Also, upon inspection of the NTFS partition, I noticed that the boot.ini file was missing??

I need to fix things so that i can boot right back into windows
Go to the top of the page
 
+Quote Post

Posts in this topic


Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 16th December 2017 - 03:46 PM