Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
> Messed up login screen configuration, Just installed Linux today, and I already screwed it up. Please help&#
PlasticCow
post Apr 24 2009, 12:24 AM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 3
Joined: 23-April 09
Member No.: 14,416



Hi everyone! Heads up, this is a long one.

I just installed version 8.10 of Ubuntu's distribution today. I know nothing about the Linux OS - but I am pretty computer-literate. I understand how command-line works, and I know a few basic unix commands from my computer science class.
However, I definitely don't know enough - and I need help.

Here's my problem:

I was attempting to install a driver for an nvidia graphics card, and it said that I needed to run the OS without "Xserver", "X", or something like that. I can't remember exactly what the name was, but in any case I believe it was referring to the graphical framework that Linux uses to display windows, icons, toolbars, and all those newfangled thingies that make up the pretty face of the OS.
After reading the README, I learned that I needed to start Linux in a lower "runlevel" - apparently there's a choice of 0, 1 ,2, 3, 4, 5, and 6. I think "X" runs on level 5 (0 is halt, 6 is reboot). It seemed that I needed to be on runlevel 1, 2, or 3 to install this driver.
So, after doing some more research, I found a command that I thought I could use to reset the default runlevel: "telinit". In a terminal, I typed "sudo telinit 3", typed in the sudo password (my username's password), and it seemed like everything went fine.
However, when I rebooted, "X" was still up! I kept seeing the desktop, windows, and toolbars! Evidently the telinit command had not worked.

So now things get really bad.

I then discovered that in the "System" menu there is an option to configure the login screen. After checking out all the tabs, I found that I could configure "Xserver" stuff. That seemed to be what was holding me up, so I decided to fiddle with it. In the config menu, there was an option I could set with a pull-down menu. I believe it was set to "Launcher" at the time. One of the other options on the menu was "Chooser". I figured that the "Launcher" option meant that "X" would load up by default, and that the "Chooser" option meant I could choose whether "X" loaded or not.
I was wrong.
When I rebooted after saving the config settings, I didn't see the nice login screen that I had seen before. Instead, I saw a little application window, all alone, with nothing else on the screen. The application seemed to let me choose "hosts" to remotely connect to, "as if you were using the console". After scanning for local hosts, nothing came up. I tried adding my computer to the list of hosts manually, by typing in the name of the machine, but a dialogue box popped up after a time-out of 3 seconds, saying "The host is either not on or not willing to respond." There was nothing else on the screen - not even a button to shut down.
However, after poking my keyboard in frustration, I found that if I press escape, the screen went out of "X" mode and into command-line mode, and I could see the terminal and even type in it. But then about 2-3 seconds after I pressed escape, it went back to the impossible, useless login screen - so I only get 3 seconds of reading/typing in the terminal at a time. This makes dealing with this issue incredibly annoying and time consuming.

So the bottom line is:
I can use terminal, albeit slowly, to somehow manually edit the config file for the login screen (if that's even a single file) and set it back to its default values.
What I need to know is where that config file lives, and what I need to change in it. Then, once my OS actually works, it would be nice to learn how I can install that nvidia driver.

Any help would be immensely appreciated, because I really want to start using Linux. To be precise, I desperately want to escape Microsoft's pathetic attempt at a shinier OS - that monster called Vista.

In any case, thanks for taking the time to read through my super-long post smile.gif

- PlasticCow
Go to the top of the page
 
+Quote Post
 
Start new topic
Replies
michaelk
post Apr 25 2009, 03:47 PM
Post #2


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,796
Joined: 23-January 03
Member No.: 360



Indeed you do not have a /etc/inittab file
http://blog.mypapit.net/2007/03/where-can-...eisty-fawn.html
Go to the top of the page
 
+Quote Post
PlasticCow
post Apr 25 2009, 04:35 PM
Post #3


Whats this Lie-nix Thing?
*

Group: Members
Posts: 3
Joined: 23-April 09
Member No.: 14,416



QUOTE (michaelk @ Apr 25 2009, 03:47 PM) *
Indeed you do not have a /etc/inittab file
http://blog.mypapit.net/2007/03/where-can-...eisty-fawn.html

Well, now I have another problem. Two problems, actually.

First, when I got the installer to run, it was unable to compile an nvidia kernel module for the driver (nor could it find a precompiled one on the ftp website).

Second, after fiddling around with the Hardware Drivers application, I realized that it had an option to enable proprietary drivers for my nvidia card. It supposedly installed the drivers, but when I restarted, the X server failed completely!

Now I can only use command line, and pressing Ctrl+Alt+F7 only gives me the message: "The X server is now disabled. Restart GDM when it is configured correctly."

Typing "sudo /etc/init.d/gdm start" doesn't do anything. Somehow, installing the driver through that utility messed up my X configuration.

Any ideas?
Go to the top of the page
 
+Quote Post

Posts in this topic


Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 18th October 2017 - 04:11 AM