Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Portforwardig
epixcore
post Aug 4 2008, 08:56 PM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 1
Joined: 4-August 08
Member No.: 13,593



Hello Community,

at this moment I have 3 Linux Boxes (Debian Etch 4.0)!
I am trying to use one of these as a "primary" server, who redirects all Requests to one of the two other boxes.

I want to use portforwarding, because the user should not see whats going on in the background.
I already have tried this method:

CODE
iptables -A PREROUTING -t nat -i eth0 -p tcp --dport 80 -j DNAT --to *.*.*.*:80
iptables -A INPUT -p tcp -m state --state NEW --dport 80 -i eth0 -j ACCEPT


this works fine, but only local, but all the servers have a Static IP Adress (81.169.134.216, 87.98.140.108, 91.121.40.164)



this should work like this:

user requests "www.mydomain.com" (A: 81.169.134.216) the Server (81.169.134.216) Redirects the Request to a extern Server => 91.121.40.164
this should not be visible for the user


does anyone know how i can fix this problem?



greets from Austria
yours Stefan



PS: Sorry for my bad english
Go to the top of the page
 
+Quote Post
chrisw
post Aug 5 2008, 10:41 AM
Post #2


RMS is my Hero
******

Group: Admin
Posts: 634
Joined: 27-September 02
From: Louisiana
Member No.: 5



QUOTE (epixcore @ Aug 4 2008, 07:56 PM) *
Hello Community,

at this moment I have 3 Linux Boxes (Debian Etch 4.0)!
I am trying to use one of these as a "primary" server, who redirects all Requests to one of the two other boxes.

I want to use portforwarding, because the user should not see whats going on in the background.
I already have tried this method:

CODE
iptables -A PREROUTING -t nat -i eth0 -p tcp --dport 80 -j DNAT --to *.*.*.*:80
iptables -A INPUT -p tcp -m state --state NEW --dport 80 -i eth0 -j ACCEPT


this works fine, but only local, but all the servers have a Static IP Adress (81.169.134.216, 87.98.140.108, 91.121.40.164)
this should work like this:

user requests "www.mydomain.com" (A: 81.169.134.216) the Server (81.169.134.216) Redirects the Request to a extern Server => 91.121.40.164
this should not be visible for the user
does anyone know how i can fix this problem?
greets from Austria
yours Stefan
PS: Sorry for my bad english



I think you need to look at using a http proxy for this situation.


--------------------

Chris W.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 15th December 2017 - 09:11 AM