Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )

Advanced DNS Management
New ZoneEdit. New Managment.


Sign Up Now
> Slow DNS lookup (no IPv6-issue???)
post Jul 6 2008, 05:32 AM
Post #1

Whats this Lie-nix Thing?

Group: Members
Posts: 3
Joined: 6-July 08
Member No.: 13,544


my dns lookups take several (~ 6-10) seconds every time. I tried a lot of things, but now I ran out of ideas. What I tried up to now is:

- Deactivate IPv6: The most common advice about slow dns lookups didn't work in my case. IPv6 is already successfully deactivated (at least "lsmod | grep ipv6" claims that), but the problem continues. Also deactivation IPv6-lookups for certain programs (like firefox or ssh) doesn't help.
- Use other nameservers: Changing the nameserver in /etc/resolv.conf to other ones didn't change anything as well. Besides, the original nameservers are working well on other systems!
- Adding "option timeout:1" to or removing "domain ..." or "search ..." lines from the /etc/resolv.conf file: Also didn't help...

Any further ideas?


PS: Distro "Debian Lenny Amd64" out of the box, only ndiswrapper installed and WLAN configured
Go to the top of the page
+Quote Post
Start new topic
post Jul 6 2008, 11:14 AM
Post #2

Whats this Lie-nix Thing?

Group: Members
Posts: 3
Joined: 6-July 08
Member No.: 13,544

Additional information:

I installed wireshark and did some analysis, what was going on, when I tried to connect to some server, for example It looked always like this:

0s : Query AAAA
2s : Query AAAA
4s : Query AAAA
4.01s : Response AAAA
4.02s : Query AAAA
6s : Query AAAA
8s : Query AAAA
8.01s : Response AAAA : No such name
8.02s : Query A
10s : Query A
12s : Query A
12.01s : Response AAAA :
12.02s : TCP Init connection with

2 interesting questions about that:
- Why does every query have to be done 3 times until a response is received???
- Why are there still AAAA-queries, if the ipv6-kernel-module is not loaded ("lsmod | grep ipv6" gives empty output!)?

Anyone any idea? Thanks!
Go to the top of the page
+Quote Post

Posts in this topic

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:


RSS Lo-Fi Version Time is now: 20th February 2018 - 10:40 PM