Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )

Advanced DNS Management
New ZoneEdit. New Managment.


Sign Up Now
Reply to this topicStart new topic
> Process getting killed automatically, cmp and diff get killed while doing their thing
post Apr 24 2008, 04:05 AM
Post #1

Whats this Lie-nix Thing?

Group: Members
Posts: 1
Joined: 24-April 08
Member No.: 13,434

I have Featherlinux running from a live CD on an old Compaq server. I've copied the contents of the various hard drive partitions on this Compaq server to a Windows share mounted via Samba.

I would like to make sure that I have an exact copy of the local files on the Compaq partitions copied to my Windows share. So I want to compare the resulting the files with the original ones, i'm using "diff" for this purpose.

I execute the command:

diff -r maal/compaq /media

The program executes for a while and then outputs the following message:


I've also tried this command, to compare file names and file sizes:

cmp `ls -R -s --block-size=1 /maal/compaq` `ls -R -s --block-size=1 /media`

Which, after some time, outputs the same:


I can't figure out what is killing it or why it is being killed.

Does anyone know how to make sure the process doesn't get killed, or, alternatively, a method for making an exact copy of some local folders to another location which also checks the copies against each other afterwards to make sure they're equal?

Thanks in advance!

EDIT: I just tried backing up with tar. Here's the result:

root@0[knoppix]# tar -cpkf 1048576 maal/compaq/back.tar.gz /media/sda2 /media/sda5 /media/sdb1
tar: Removing leading `/' from member names
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:


RSS Lo-Fi Version Time is now: 17th July 2018 - 07:03 AM