Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )

Advanced DNS Management
New ZoneEdit. New Managment.


Sign Up Now
> FSCK, boot problem
post Mar 9 2008, 01:56 PM
Post #1

Whats this Lie-nix Thing?

Group: Members
Posts: 6
Joined: 9-March 08
Member No.: 13,368

Hi, I had mandriva 2007 and I upgraded it to 2008 using a DVD upgrade.
I was able to login the first time and I used the pc for about 2 hours.
I was installing some development programs when the system froze.
I switch it off using the button, when I tried to log back in I got an error at boot time.
This is the error message:

fsck.ext2: is a directory while trying to open /
The superblock could not be read or does not describe a correct ext2 filesystem.
if the device is valid and it really contains an ext2 file system(and not a swap of ufs or something else), then the superblock is corrupt, and you might try running e2fsck with an alternate superblock:
e2fsck -b 8193 <device>

when I run e2fsck this is what I get:

fsck: fsck.swap not found
fsck: error 2 while executing fsck.swap

it can not fix it...what can I do?
Go to the top of the page
+Quote Post
Start new topic
post Mar 9 2008, 07:11 PM
Post #2

Its GNU/

Group: Support Specialist
Posts: 1,807
Joined: 23-January 03
Member No.: 360

First I would boot using a rescue CD or a live CD. You can try running fsck from CD specifying a partition.

Do you know how the drive is partitioned?
What filesystems are you using for each partition i.e. ext2/3 reiserfs etc.
Go to the top of the page
+Quote Post

Posts in this topic

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:


RSS Lo-Fi Version Time is now: 22nd July 2018 - 11:17 PM