Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Rpm
Steph
post May 4 2003, 04:46 PM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 2
Joined: 4-May 03
Member No.: 781



It all started trying to get openssh to work on Redhat 6.2.

I found 2 different examples online of how to do this.

The first one was this:

"why not get the openssl shim libs:
ftp.redhat.com/pub/redhat/linux/7.2/en/os/i386/SRPMS/openssl095a-0.9.5a-11.src.rpm

and newer openssl:
ftp.redhat.com/pub/redhat/linux/7.2/en/os/i386/SRPMS/openssl-0.9.6b-8.src.rpm

and recompile on RH6.2
then build openssh. worked for me

rpm --rebuild openssl095a-0.9.5a-11.src.rpm
rpm --rebuild openssl-0.9.6b-8.src.rpm
rpm -Uvh openssl*
rpm --rebuild openssh-3.1p1-2.src.rpm
rpm -Fvh openssh-* "


The first time I tried this, I ran the first line, and it said I need python-devel and something else. Like I was supposed to know. So being impatient, I tried the second way.

This way suggests these files:

openssh-clients-2.5.2p2-1.i386.rpm
openssh-server-2.5.2p2-1.i386.rpm
openssh-2.5.2p2-1.i386.rpm
db3-3.1.17-4.6x.i386.rpm
rpm-4.0.2-6x.i386.rpm
zlib-1.1.3-6.src.rpm
openssl-0.9.5a-2.6.x.i386.rpm

Ok so I had the correct version of zlib already, so the doc states I need to upgrade my version of rpm before I can proceed. But first I must install db3-3.1.17-4.6x, so I did. Then I installed the rpm-4.0.2-6x. Then the doc states to do a:

rpm --rebuilddb

to install db3. Whatever, don't really clearly understand, but ok. Then I did a:

rpm -Uhv openssl-0.9.5a-2.6.x.i386.rpm

Ok that worked. Then I did:

rpm -Uhv openssh-2.5.2p2-1.i386.rpm

Nope, that failed, glibc version is wrong, and some other version of something is wrong as well. Great, this is par for most docs I come across. And I really don't want to try and change glibc.

So I go back to the first way again, thinking I will get python-devel and whatever else.

I get the files, try and run the first line and rpm comes up with the list of options like I typed something wrong. Tried again, same thing, the option list doesn't show --rebuild, yet the man pages do. Ok now I'm thinking I f'd up rpm with the upgrade I did during the second way I tried. Because the --rebuild option WAS working.

So now I'm gettin p.o., so I try and downgrade the rpm back to the version I had, 3 something, and I get a message stating I have a newer version, so it wont let me. So smart as I am, I did a:

rpm -Uvh --force rpm-3.(whatever it was, got it online), and dangit, now I try:

rpm -v

And I get version 3 whatever, but when I try and install rpm's now, or do other rpm things, I get a list of failed dependencies, like gawk, glibc, etc., looks like all the stuff rpm relies on, like the pointers are busted, but it seems everything else is ok, and it seems gawk and what not is still there.

So, first of all, how can I fix rpm, and did I slam something else?

Second, does anybody have a reliable, uncryptic method of getting openssh installed on RedHat 6.2?
I almost had it with non-rpm files I found, but could never authenticate because of access denied errors. So I tried the rpm method.

RedHat 7.1 works great, even got vnc/putty to port forward X11 with ssh. But this 6.2 box I'm afraid must stay 6.2 for production application reasons.

Thanks in advance for any help,

Steph
Go to the top of the page
 
+Quote Post
Corey
post May 5 2003, 06:19 AM
Post #2


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 1,254
Joined: 21-September 02
From: St John's, Newfoundland, Canada
Member No.: 3



Yeah, welcoem to dependancy hell. While Redhat 6.2 was a great release, it was a great release *at the time*. Redhat 6.2 is quite old now, and getting newer rpm's installed on there is next to impossible. My suggestion would be to download the openssh sources directly from www.openssh.org, and install it like this:

QUOTE
tar zxvf openssh-xxxxx.tar.gz
cd openssh-xxxxxx
./config
make
make test
su -c make install


I'm typing this out by memory, but you should check the INSTALL file to make sure smile.gif


--------------------
Corey Quilliam
(former) Linuxhelp.ca Administrator
cquilliam-AT-gmail-dot-com

Want to help out Linuxhelp.net? Check out our Linuxhelp Wiki and see if there are some articles you would like to submit!!

--
Ubuntu 8.04 64-bit - Work Laptop (HP-Compaq NC6400 Core2)
Kubuntu 8.04 64-bit - Desktop (HP m8120n QuadCore)
Ubuntu 6.04 - Server (I'm not upgrading this baby until support runs out in 2012) (Some old POS dell)
Go to the top of the page
 
+Quote Post
Steph
post May 5 2003, 09:23 AM
Post #3


Whats this Lie-nix Thing?
*

Group: Members
Posts: 2
Joined: 4-May 03
Member No.: 781



Thanks for reply.

Like I said, "I almost had it with non-rpm files I found, but could never authenticate because of access denied errors. So I tried the rpm method."

That meant I did exactly what you suggested first. Compile myself. It all worked ok, just could never authenticate, even ssh localhost would not work. And I did try to compile with/without many options, such as pam. Still nothing.

Anyways, I would still like to fix my broken rpm??

Yes 6.2 is old, but at the time, it was and still is one of the only reliable OS's that will run Oracle8i, which we must have. We have Oracle9i on 7.1. We need both. The "old" 6.2 has proven itself with Oracle8i, so we use it.

It's either that or install Oracle8i on MS server 2000, which we have tried and don't like for various reasons.

Steph
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 23rd October 2017 - 06:49 AM