Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )

Advanced DNS Management
New ZoneEdit. New Managment.


Sign Up Now
Reply to this topicStart new topic
> I changed Permissions, now I cannot get anywhere? Help!!
post Jan 26 2008, 07:16 AM
Post #1

Whats this Lie-nix Thing?

Group: Members
Posts: 9
Joined: 10-January 08
Member No.: 13,245

Hello and thanks for reading.....

I recently tried to install some games such as MAME and needed to change the permission of the USR folder because I could not copy any roms into the error came up and said that I did not have permission to do so.

I went into termninal and became the root (Ubuntu), and typed--

chmod /usr -rwxrwxrwx...or something like that..I know, I know...what the heck am I doing? I have no idea...

Well, I guessed it worked because all the icons changed into something else and the system went out.
Tried to restart ( and shut off, then on )...only thing that comes up is a box with a big red circle and a bunch of little letters, just little symbols that I cannot read.

There is a box you can click, but it has squares too, no letters. Click on it, and the same thing happens over and over...nothing!

Can this be fixed or do I need to re-install everything.
And I just got all those neat 3-D effects working!!! AARRGGHHH!!!!

If anyone can help, it would be appreciated!

Thank you,
Go to the top of the page
+Quote Post
post Jan 26 2008, 09:54 AM
Post #2

Its GNU/

Group: Support Specialist
Posts: 1,806
Joined: 23-January 03
Member No.: 360

I have not played with Ubuntu so not sure what files are in /usr. However, typically /usr is for user programs, source code, man pages etc but no system files that I know of. However, changing file permissions globally can be very dangerous since many programs must be run by root or a particular user. You can not globally undo a chmod command since files permissions are not the same even in the same directory. So yes it could be fixed if you had a backup or if you knew the permissions of every file and you take the time to manually change each one. So a reinstall is really the best solution. lesson learned....
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:


RSS Lo-Fi Version Time is now: 19th March 2018 - 05:26 AM